Bug 759818 - Review Request: buffer - General purpose buffer program
Review Request: buffer - General purpose buffer program
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
:
Depends On:
Blocks: mondo
  Show dependency treegraph
 
Reported: 2011-12-03 20:01 EST by Bruno Cornec
Modified: 2016-02-07 20:16 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-07 20:16:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
msuchy: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Bruno Cornec 2011-12-03 20:01:02 EST
Description of problem:

Re-activate the buffer package (Description: General purpose buffer program) in Fedora

Version-Release number of selected component (if applicable):
1.19

Additional info:

This has been built in the past:
https://bugzilla.redhat.com/show_bug.cgi?id=462982

And has been retired:
http://pkgs.fedoraproject.org/gitweb/?p=buffer.git;a=blob;f=dead.package;h=6c90bdc8768fc421bae28dabe5c08e13cbcd8a84;hb=4a2e8f905b7e3ee5d6c199b6d7e370f80cc9f18f but the reason doesn't seem obvious (I'm building it for each fedora release myself)

I have a latest version at ftp://ftp.mondorescue.org//fedora/16/x86_64/buffer-1.19-4.fc16.src.rpm with the SPEC at ftp://ftp.mondorescue.org//fedora/16/x86_64/buffer.spec

TIA for your help.
Comment 1 Fedora End Of Life 2013-04-03 10:52:24 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19
Comment 2 Bruno Cornec 2013-08-29 17:35:21 EDT
I'm happy to provide info, but I don't know which one is asked.

Latest package available at:
ftp://ftp.mondorescue.org/fedora/17/x86_64/buffer.spec and ftp://ftp.mondorescue.org/fedora/17/x86_64/buffer-1.19-4.fc17.src.rpm
Comment 3 Christopher Meng 2013-08-30 00:09:21 EDT
Hi,

Can you upload it to another place, I've tried about 10 minutes and Chrome always tells me "Oops! Google Chrome could not connect to ftp.mondorescue.org"

FTP --> HTTP?

And have you register an account at FAS? If so please tell me your FAS username.
Comment 4 Bruno Cornec 2013-08-30 04:38:08 EDT
Could you try with a CLI ftp tool to check ? I have no problem from home to access to it (hosted at work) neither yesterday when I answered, nor today.

It's an ftp server (upstream of the project)

I also made updated versions for fedora 18 and 19, as well at 
ftp://ftp.mondorescue.org/fedora/19/x86_64/buffer-1.19-4.fc19.src.rpm and ftp://ftp.mondorescue.org/fedora/19/x86_64/afio.spec

My FAS account is bcornec.
Comment 5 Christopher Meng 2013-09-06 12:36:49 EDT
I hope you can find a sponsor quickly.

http://fedoraproject.org/wiki/How_to_get_sponsored_into_the_packager_group
Comment 6 Michael Schwendt 2013-10-24 04:27:05 EDT
Wrong bugzilla "Component". Ticket has been visible only for retired package "buffer" http://bugz.fedoraproject.org/buffer
Comment 7 Michael Schwendt 2013-10-29 15:50:19 EDT
Package for re-review should be based on the last build in the distribution:

http://kojipkgs.fedoraproject.org//packages/buffer/1.19/7.fc15/src/buffer-1.19-7.fc15.src.rpm
[ http://koji.fedoraproject.org/koji/packageinfo?packageID=7297 ]

In "buffer-1.19-4.fc19.src.rpm" found in this ticket, even the included source tarball is a different one.
Comment 8 Miroslav Suchý 2015-08-17 08:22:30 EDT
Please use macros consistently
I.e. instead of $RPM_BUILD_ROOT please use %{buildroot}.

BuildRoot tag is not needed unless you target EL5.

French translation of description:
 1) does not start with capital
 2) does not end with dot
 3) is not full translation of the original text
Therefore I would suggest to remove it completly.

%install
%{__rm} -rf $RPM_BUILD_ROOT
is not needed unless you target EL5

The same for
%clean
%{__rm} -rf $RPM_BUILD_ROOT

and
%defattr(-,root,root,-)

You should mark COPYING as license. i.e. use
%license COPYING

Dist tag should be used conditionally:
%{?dist}


- Sources used to build the package match the upstream source, as provided
  in the spec URL.
  Note: Upstream MD5sum check error, diff is in /tmp/review-buffer/diff.txt
  See: http://fedoraproject.org/wiki/Packaging/SourceURL
Comment 9 Miroslav Suchý 2015-10-01 06:26:35 EDT
Ping! Any progress?
Comment 10 Bruno Cornec 2015-10-04 19:39:53 EDT
Hello Miroslav !

Sorry for the delay and having missed the previous notice. I have updated the spec file and the src.rpm as well following your feedback. Hope it's in better shape now.

Now available at ftp://ftp.mondorescue.org/test/fedora/21/x86_64/buffer-1.19-8.fc21.src.rpm and ftp://ftp.mondorescue.org/test/fedora/21/x86_64/buffer.spec
Comment 11 Michael Schwendt 2015-10-05 06:09:03 EDT
> has been retired:
> but the reason doesn't seem obvious
> (I'm building it for each fedora release myself)

Build history is this:

  http://koji.fedoraproject.org/koji/packageinfo?packageID=7297

After conversion to dist-git, package has been auto-rebuilt once but apparently failed during the mass-rebuilds for F16 (and later) in 2011. Very likely due to compiler changes. Typically, the package maintainers at that time have received FTBFS notifications and could have looked into it.

It seems you've been the package maintainer for this before (via FAS account "bcornec"), and later the package has been adapted by somebody else for some time:

  http://pkgs.fedoraproject.org/cgit/buffer.git/log/

As pointed out before, some of the review tickets have not been visible on the review queue tracker page for a long time because they been filed incorrectly.

mindi: bug 187317
mondo: bug 187318
mindi-busybox: bug 476234
Comment 12 Miroslav Suchý 2015-10-05 07:39:36 EDT
The description should be wrapped to 80 characters.
https://fedoraproject.org/wiki/Packaging:Guidelines#Summary_and_description

You should provide the spec file which you really used for building SRC.RPM.
Your spec use dist tag macro, while your src.rpm file contains spec which have value of dist tag hardcoded.

Any reason why AUTHORS NEWS are not included in binary package?
I would recommend to use:
  %doc README AUTHORS NEWS

buffer.x86_64: E: incorrect-fsf-address /usr/share/licenses/buffer/COPYING
You should containt upstream so they update they license file. However, you should not alter the file yourself!
Comment 13 Bruno Cornec 2015-10-06 20:15:35 EDT
I suppose you have a tool which could help me fix most of the errors/warnings alone right ? Any pointer ? Meanwhile I fixed it.

I'm now indeed providing the right spec file corresponding to the build, sorry for that.

I didn't include AUTHORS and NEWS as they do not exist ;-) I removed the comment line mentioning them to avoid questions.

Latest version updated here:
ftp://ftp.mondorescue.org/test/fedora/21/x86_64/buffer.spec
ftp://ftp.mondorescue.org/test/fedora/21/x86_64/buffer-1.19-8.fc21.src.rpm
Comment 14 Miroslav Suchý 2015-10-07 04:09:21 EDT
(In reply to Bruno Cornec from comment #13)
> I suppose you have a tool which could help me fix most of the
> errors/warnings alone right ? Any pointer ? 

dnf install fedora-review
fedora-review -b 759818

However the biggest tools are my own eyes, compare everything provided with SRPM and RPM and with upstream. Check the spec for stuff which should not be there etc.
Comment 15 Miroslav Suchý 2015-10-07 08:15:50 EDT
(In reply to Miroslav Suchý from comment #12)
> buffer.x86_64: E: incorrect-fsf-address /usr/share/licenses/buffer/COPYING
> You should containt upstream so they update they license file. However, you
> should not alter the file yourself!

Did you contact upstream about this one?
Comment 16 Miroslav Suchý 2015-10-07 08:25:44 EDT
Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated


===== MUST items =====

C/C++:
[x]: Package does not contain kernel modules.
[x]: Package contains no static executables.
[x]: Package does not contain any libtool archives (.la)
[x]: Rpath absent or only used for internal libs.

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[ ]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Useful -debuginfo package or justification otherwise.
[x]: Package is not known to require an ExcludeArch tag.
[-]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 10240 bytes in 1 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[-]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[?]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[!]: Patches link to upstream bugs/comments/lists or are otherwise
     justified.
     -- it is clear to my why those patches are there, so I leave it as is.
[x]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Uses parallel make %{?_smp_mflags} macro.
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on debuginfo package(s).
     Note: There are rpmlint messages (see attachment).
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Large data in /usr/share should live in a noarch subpackage if package
     is arched.
[x]: Spec file according to URL is the same as in SRPM.

Everything is fine. So once you contact upstream about the license, I will give you approval stamp.
Comment 17 Bruno Cornec 2015-10-07 13:18:04 EDT
(In reply to Miroslav Suchý from comment #15)
> (In reply to Miroslav Suchý from comment #12)
> > buffer.x86_64: E: incorrect-fsf-address /usr/share/licenses/buffer/COPYING
> > You should containt upstream so they update they license file. However, you
> > should not alter the file yourself!
> 
> Did you contact upstream about this one?

Yes I just did that. As there has been no new version since 2000, I'm not sure whether the author will answer, but we'll see.
Comment 18 Miroslav Suchý 2015-10-08 02:24:53 EDT
OK then approved.
I will watch your initial steps. Any moments you have some question about Fedora procesess do not hesitate to ask me directly via email.

BTW your email in FAS:
  https://admin.fedoraproject.org/accounts/user/view/bcornec
is different from your bugzilla email. You should have the same email otherwise several things will not work.
You need to sync it up before requesting dist-git branch.

APPROVED
Comment 19 James Hogarth 2015-12-03 19:53:08 EST
This is coming up to two months since it was approved but no git requests appear to have been made.

As per the stalled review policy if there is no progress in the next week this bug will be closed and a fresh review will be required should anyone want to progress this into Fedora

https://fedoraproject.org/wiki/Policy_for_stalled_package_reviews
Comment 20 Bruno Cornec 2015-12-05 20:36:30 EST
Sorry for the delay, lots of business travels recently. Will do my best to make progresses ASAP.
Comment 21 Bruno Cornec 2015-12-05 21:49:39 EST
I may have issue with myaccount. When trying to login to cjeck the above report I get:

500 Internal error

The server encountered an unexpected condition which prevented it from fulfilling the request.

Powered by CherryPy 2.3.0
Comment 22 Miroslav Suchý 2015-12-07 04:32:06 EST
You should now login to pkgdb and click on 'request new package'. Fill in the form with the required information and submit. Your request will be processed by admins usually within 24 hours. 
  https://admin.fedoraproject.org/pkgdb
If you cannot log in there, please either hop into #fedora-admin on irc.freenode.net (faster) or file ticket at 
  https://fedorahosted.org/fedora-infrastructure/report
however you need to be logged there to file ticket. So if you are unable to log in, then try the IRC.
Comment 23 Bruno Cornec 2015-12-14 20:38:41 EST
The package already exists so I can't ask for "request new package". I've installed a build env for rawhide, and tried koji build (seems to work) and $ fedpkg build:                               
Could not execute build: There are unpushed changes in your repo
-bash-4.3$ fedpkg push
Enter passphrase for key '/home/bruno/.ssh/id_rsa': 
FATAL: W any buffer bcornec DENIED by fallthru
(or you mis-spelled the reponame)
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

I've tried to read and understand the wiki for that, but that problem doesn't seem to be covered. Could you help me once more ?
Comment 24 Miroslav Suchý 2015-12-15 08:59:14 EST
You need to follow:
https://fedoraproject.org/wiki/PackageDB_admin_requests#Other_requests

Ie. open rel-eng ticket and put there link to this review and ask to be assigned as owner for master branch and all other branches you like (e.g. epel7, f23).
Comment 25 Pierre-YvesChibon 2015-12-16 03:22:41 EST
Since the package is retired, the proper way is to ask on pkgdb for it to be un-retired (login and see the button on: https://admin.fedoraproject.org/pkgdb/package/buffer/ )
Comment 26 Bruno Cornec 2015-12-16 14:43:23 EST
Done with https://fedorahosted.org/rel-eng/ticket/6314
Comment 27 Pierre-YvesChibon 2015-12-17 01:45:39 EST
But that's not pkgdb, is it?
Comment 28 Bruno Cornec 2015-12-17 19:32:31 EST
No it wasn't as I was answering to the other proposal :-(

If I try to unretire it I get:
"Could not save the request for branch: master, has it already been requested?"
Comment 29 Miroslav Suchý 2016-01-07 08:22:03 EST
I just tried to click on un-retire button and did not get the mentioned error. Did you click on "master" in Branches select box?
Comment 30 Miroslav Suchý 2016-01-07 12:56:39 EST
Bruno I just gave you the ownership. Try clonning the repo and push the package there.
Comment 31 Bruno Cornec 2016-01-29 05:31:36 EST
I've been able to successfully build the buffer package using fedpgk scratch-build

However, my build is unsuccessful as the package is still blocked:

fedpkg build        
Building buffer-1.19-8.fc24 for rawhide
Created task: 12722507
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=12722507
Watching tasks (this may be safely interrupted)...
12722507 build (rawhide, /buffer:b4ad6f02c953dfe2b4abbd25021ef0da61517e82): open (buildppcle-08.phx2.fedoraproject.org)
  12722508 buildSRPMFromSCM (/buffer:b4ad6f02c953dfe2b4abbd25021ef0da61517e82): free
  12722508 buildSRPMFromSCM (/buffer:b4ad6f02c953dfe2b4abbd25021ef0da61517e82): free -> open (arm02-builder04.arm.fedoraproject.org)
  12722508 buildSRPMFromSCM (/buffer:b4ad6f02c953dfe2b4abbd25021ef0da61517e82): open (arm02-builder04.arm.fedoraproject.org) -> closed
  0 free  1 open  1 done  0 failed
12722507 build (rawhide, /buffer:b4ad6f02c953dfe2b4abbd25021ef0da61517e82): open (buildppcle-08.phx2.fedoraproject.org) -> FAILED: BuildError: package buffer is blocked for tag f24
  0 free  0 open  1 done  1 failed

12722507 build (rawhide, /buffer:b4ad6f02c953dfe2b4abbd25021ef0da61517e82) failed

Seems blocked on purpose:$ koji list-pkgs --show-blocked --package buffer
Package                 Tag                     Extra Arches     Owner          
----------------------- ----------------------- ---------------- ---------------
buffer                  dist-f8                                  bcornec        
buffer                  dist-f9                                  bcornec        
buffer                  dist-f11                                 orphan         
buffer                  f11-alpha                                bcornec        
buffer                  f11-alpha-2                              bcornec        
buffer                  f11-beta                                 bcornec        
buffer                  f11-final                                bcornec        
buffer                  f12-alpha                                bcornec        
buffer                  f9-cutoff                                bcornec        
buffer                  f9-build-cutoff                          bcornec        
buffer                  f12-beta                                 bcornec        
buffer                  f12-final                                bcornec        
buffer                  f16                                      orphan          [BLOCKED]
buffer                  rawhide                                  orphan         
buffer                  f18                                      orphan          [BLOCKED]
buffer                  f17-final                                orphan          [BLOCKED]
buffer                  f18-Alpha                                orphan          [BLOCKED]
buffer                  dist-f15-eol                             orphan         
buffer                  f18-Beta                                 orphan          [BLOCKED]
buffer                  f18-final                                orphan          [BLOCKED]
buffer                  f21                                      bcornec         [BLOCKED]
buffer                  f22                                      bcornec         [BLOCKED]
buffer                  f21-beta                                 orphan          [BLOCKED]
buffer                  f22-Alpha                                orphan          [BLOCKED]
buffer                  f22-Beta                                 orphan          [BLOCKED]
buffer                  f23_Alpha                                orphan          [BLOCKED]
buffer                  f23_Beta                                 orphan          [BLOCKED]


I've opened the following ticket: https://fedorahosted.org/rel-eng/ticket/6345

Hopefully either on your side or their side the package will be unblocked allowing me to upload.
Comment 32 Bruno Cornec 2016-02-07 20:16:02 EST
I've finally build the buffer package successfully for f24. I think we can now close this ticket :-)

Note You need to log in before you can comment on or make changes to this bug.