Bug 75982 - heavy problems with German Umlauts
heavy problems with German Umlauts
Product: Red Hat Linux
Classification: Retired
Component: kde-i18n (Show other bugs)
athlon Linux
high Severity high
: ---
: ---
Assigned To: Petr Rockai
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2002-10-15 11:11 EDT by Draco Dragon
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-02-14 08:48:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
example file which couldn't be opened/copied by Konqueror (18.67 KB, image/gif)
2002-10-24 04:37 EDT, Draco Dragon
no flags Details

  None (edit)
Description Draco Dragon 2002-10-15 11:11:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Every single Application on my new RedHat 8.0 installation (previously i used
RedHat 7.2) can't handle German Umlauts correctly.
I use my complete linux with 'english' as selected language. Konqueror can't
copy/move files with Umlauts in the names, konsole just doesn't display any
umlaut (and it displays little square boxes instead of a dash...)
Licq doesn't show the umlauts, too.
That's a really big problem for me! It's nearly impossible to work with that system!
The Gnome Terminal has the same problems.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
search for files created with redhat 7.x which contain Umlauts and try opening
them in konquerer e.g.

Actual Results:  the umlauts aren't displayed

Expected Results:  that's obvious... stupid form ;)

Additional info:
Comment 1 Draco Dragon 2002-10-15 11:49:32 EDT
I have to add that if I enter the umlauts *now*, after the installation of 
RedHat 8.0, they appear correctly.  
Only files which have these umlauts in the name, created with old RedHat 
version can't be read/written. 
Licq however doesn't show the Umlauts someone sends me, but only those which I 
enter... and those I enter noone else can read...
Comment 2 Ngo Than 2002-10-23 15:39:45 EDT
It's very strange. konnqueror opens a old file including Umlaut without this
issue on my machine. Could you please attach your test file for testing? thanks

move/copy filename with Umlaut works for me, too.

licq needs to have utf8 support.
Comment 3 Draco Dragon 2002-10-24 04:37:32 EDT
Created attachment 81884 [details]
example file which couldn't be opened/copied by Konqueror
Comment 4 Draco Dragon 2002-10-24 04:43:25 EDT
Hi, i sent an example file (gif) with an Uuml in it. 
I also would like to add that I solved the Umlaut Problem by editing the 
/etc/sysconfig/i18n file and deleting the "UTF-8" in all lines... It works for 
me at the moment, with most application - but as I see now, the konqueror in 
which I type this message displays an | instead of the u-uml...
Comment 5 Dennis Kehrig 2002-11-04 05:41:01 EST
Hey, finally I found someone with the same problem :)

I searched Google and found the UTF-8 thing, too. Though the original poster 
just changed from en_US.UTF-8 to de_DE.UTF-8 (which didn't help). I thought for 
myself: let's try removing "UTF-8" when I'm at home again. So it more or less 
solves the problem for you? I will try, too.

By the way: I never had Red Hat 7.2. I just want to use the files on my FAT-32 
partitions. Or read manpages - they have problems with umlauts as well.

BTW: the name of the Doppelw|rfel-Attachment ist displayed as Doppelw|rfel.gif -
 here on Win2k with IE... how did you post that attachment? Using Linux - and 
which browser? If you used Konqueror, does Mozilla have the same problem?

This (RH 8) is the fourth (?) Linux distro I'm trying (starting with SUSE 6.3 
some years ago), but the first time I'm taking it serious. I had some problems 
with it and solved some of them, but the umlaut problem is a serious one.
Comment 6 Dennis Kehrig 2002-11-04 05:43:27 EST
Okay, so the problem with the attachment name seems to be Bugzilla (or the 
combination of IE and Bugzille) since i used the real "u" umlaut, not "|".
Comment 7 Ngo Than 2002-12-11 10:46:36 EST
It's utf8 problem here. If you set LANG=de_DE in /etc/sysconfig/i18n. It should
Comment 8 Petr Rockai 2005-02-14 08:48:36 EST
Konqueror doesn't seem to have any problems with filenames in fedora core 3,
when locale is set to UTF-8 one (which is default). Non-utf-8 locales don't work
at all with non-ascii filenames. Forwarding the bug upstream.

Note You need to log in before you can comment on or make changes to this bug.