Bug 75983 - need the --nodeps flag when installing rpm
Summary: need the --nodeps flag when installing rpm
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Developer Suite
Classification: Retired
Component: eclipse (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tom Tromey
QA Contact: Tom Tromey
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-15 15:18 UTC by Need Real Name
Modified: 2014-08-11 05:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-15 15:18:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-10-15 15:18:32 UTC
Description of Problem:
Can't install rpm without --nodeps flag although have the jre in the required
location.

I have installed the following SDK and JRE:
IBMJava2-JRE-1.3.1-2.0.i386.rpm     
IBMJava2-SDK-1.3.1-2.0.i386.rpm

This created a directory called /opt/IBMJava2-131 dir which had a jre dir in it
too. 

installing the rpm using 
rpm -i  eclipse-linux-gtk-2.0.1-9.i386.rpm

causes the error:
error: failed dependencies:
	/opt/IBMJava2-13/jre is needed by eclipse-linux-gtk-2.0.1-9 
to appear.

So I renamed the java directory from /opt/IBMJava2-131 to /opt/IBMJava2-13. 
Now the jre is in the same path as above yet the same error is produced when
tryign to install. If I install with the --nodeps flag set, Eclipse installs and
runs fine.

Comment 1 Tom Tromey 2002-10-15 16:18:04 UTC
We standardized on the 1.3 JDK from IBM, not 1.3.1.
That is the root of the problem here.

Renaming the directory won't work, because dependencies
are based on the RPM that is installed, not the files that
exist -- that is, renaming the directory doesn't affect
what is recorded in the RPM database.

Could you uninstall 1.3.1 and install 1.3 instead?
If 1.3 isn't available, tell me and I'll reopen this report;
I think that would indicate it is time for all of us to upgrade.


Comment 2 David Lawrence 2003-12-11 19:23:25 UTC
Changing product to RHEL.

Comment 3 John Healy 2004-03-08 21:21:32 UTC
Moving from RHEL/3/Eclipse to Red Hat Developer Suite product.


Note You need to log in before you can comment on or make changes to this bug.