Bug 75988 - problem restoring workbench
problem restoring workbench
Product: Red Hat Developer Suite
Classification: Retired
Component: eclipse (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: eclipse-bugs
Tom Tromey
Depends On:
  Show dependency treegraph
Reported: 2002-10-15 12:15 EDT by Need Real Name
Modified: 2014-08-11 01:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-11-01 10:48:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-15 12:15:22 EDT
The second time Eclipse is started, (also the second time its started after the
workspace directory is deleted) the terminal window outputs the error:
"Unable to restore editor - createElement returned null for input
element factory:

and a "Problems" dialog box pops up upon start up that says:

"Could not restore workbench layout. Reason: problems occurred restoring
Under the Details >> button:
"unable to restore perspective: Workspace development.
Unable to create editor: Welcome"

basically, the Welcome editor can't be opened so the workench can't be

If I close the problems box, exit out of Eclipse, and restart it, the problem
error no longer appears yet the Welcome editor also doesn't show up.
Comment 1 Need Real Name 2002-11-01 10:52:27 EST
Fixed. Verified on the latest rpm:
Workbench restores without errors eachtime the Eclipse platform is launched. 

Note You need to log in before you can comment on or make changes to this bug.