Bug 760 - static-routes gets rewritten by netcfg in wrong order
Summary: static-routes gets rewritten by netcfg in wrong order
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: netcfg   
(Show other bugs)
Version: 5.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-01-09 15:52 UTC by Andrew Maffei
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-29 17:20:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrew Maffei 1999-01-09 15:52:36 UTC
I often have to modify my static-routes file and insert
routes in a certain order. The order matters because
sometimes a later route depends on the successful setting of
an earlier route.

If I then use netcgf and "SAVE" the order of the routes
changes in static-routes and my routing configuration is
really messed up.

Comment 1 David Lawrence 1999-01-12 23:58:59 UTC
I have verified this to be true. I used netcfg to add two static
routes. Whichever one was on the bottom of the list gets pushed to the
top of the /etc/sysconfig/static-routes file. Then if you add another
one later, it shows up in the bottom of the list in netcfg, but when
you save the file the new entry is thrown to the top of the list in
the static-routes file. Ideally you should be able to move the routes
around in order using netcfg and then have the static-routes file
written in the proper order.

Comment 2 Michael K. Johnson 1999-03-26 01:43:59 UTC
Unfortunately, netcfg does write static routes in random order.
While we may fix this later, I believe that linuxconf will keep
the routes ordered appropriately, and I suggest that you use
linuxconf to maintain the routes instead.

Comment 3 Jay Turner 1999-06-29 17:20:59 UTC
Discarding as linuxconf is the recommended method for maintaining
routing tables.

------- Email Received From  Andrew Maffei <amaffei@whoi.edu> 06/29/99 15:55 -------


Note You need to log in before you can comment on or make changes to this bug.