Bug 76000 - rhn-applet-tui does not use IgnoredPackages from ~/.rhn-applet.conf
rhn-applet-tui does not use IgnoredPackages from ~/.rhn-applet.conf
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rhn-applet (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
Beth Nackashi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-15 13:20 EDT by rruth
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version: 2.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-07 13:11:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rruth 2002-10-15 13:20:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020829

Description of problem:
rhn-applet-tui does not ignore the package(s) listed in my ~/.rhn-applet.conf
file.  (IgnoredPackages=)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Replaced gnuplot with gnuplot-3.7.1-17 from RH 7.3
2. Started Xwindows
3. Looked at the window from rhn-applet-gui.  It stated there was a newer 
version of gnuplot, as it should.
4. I instructed rhn-applet-gui to ignore gnuplot. 
5. Tested rhn-applet-gui again -- it showed no packages needed updating
6. Exited out of Xwindows
7. Looked at ~/.rhn-applet.conf
   Here is the relevant line:
IgnoredPackages=gnuplot
8. ran rhn-applet-tui

it still showed that I needed gnuplot

Actual Results:  $ rhn-applet-tui 
could not figure out kernel

The following is a list of outdated packages on your system:

Name                                     Version         Release             
--------------------------------------------------------------------
gnuplot                                  3.7.2           1                   

(The kernel message is expected because I am running 2.4.19)


Expected Results:  None ... rhn-applet-tui should not have reported any packages
to update

Additional info:
Comment 1 Daniel Veillard 2002-11-05 08:55:10 EST
Okay I have a fix locally for this, this should be corrected in the
next release.

Daniel
Comment 2 Robin Norwood 2005-10-07 13:11:06 EDT
Confirmed fixed long ago.

Note You need to log in before you can comment on or make changes to this bug.