Bug 76001 - gcc error: cannot convert `_G_fpos64_t' to `streampos'
gcc error: cannot convert `_G_fpos64_t' to `streampos'
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-15 13:29 EDT by Eric McRae
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-22 03:22:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric McRae 2002-10-15 13:29:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18-10 i686)

Description of problem:
I have gcc 2.96 and glibc-*2.2.5-40 installed.  I cannot compile even a simple
C++ hello world without the following error.
[eric@luna ~]$ g++ hello.cc
In file included from /usr/include/g++-3/iostream.h:31,
                 from hello.cc:1:
/usr/include/g++-3/streambuf.h: In method `streampos 
streambuf::pubseekoff (long long int, ios::seek_dir, int)':
/usr/include/g++-3/streambuf.h:362: cannot convert `_G_fpos64_t' to 
`streampos' in return
/usr/include/g++-3/streambuf.h: In method `streampos 
streambuf::pubseekpos (long long int, int)':
/usr/include/g++-3/streambuf.h:364: conversion from `streampos' to 
non-scalar type `_G_fpos64_t' requested


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. upgrade gcc to 2.96
2. upgrade glibc to 2.2.5-40 (glibc-devel-2.2.5-40, glibc-2.2.5-40,
glibc-common-2.2.5-40, glibc-utils-2.2.5-40 )
3. Create the following file as hello.cc.
#include <iostream.h>

main()
{
    cout << "Hello World!" << endl;
}
4. compile this file with gcc hello.cc
	

Actual Results:  See description

Expected Results:  successful compile

Additional info:

I have seen commentary on the net that a compatibility patch is needed for glibc
to work with gcc versions older than 3.2.  Since you are providing gcc 2.96, I
think a patch is needed - particularly for /usr/include/_G_config.h.
Comment 1 Alan Cox 2002-12-15 20:31:16 EST
Checks out OK in 8.0/gcc 3.2
Comment 2 Ulrich Drepper 2003-04-22 03:22:32 EDT
You didn't use the correct libg++/libstdc++ code.   There is in any case no
problem with RHL8 and especially RHL9 since the C++ library is completely
different.  Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.