Bug 760022 - Add netKVM driver for winxp and win7 guest in VFD file
Summary: Add netKVM driver for winxp and win7 guest in VFD file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win
Version: 6.2
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: ---
Assignee: Jay Greguske
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 840699 840829 853315 853319 1028749
TreeView+ depends on / blocked
 
Reported: 2011-12-05 09:05 UTC by Mike Cao
Modified: 2015-09-28 02:18 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In the previous version, the virtio-win floppy disk does not contain NDIS drivers for Windows XP and Windows 7 platforms due to lack of free space on VFD media. The current release fixes this problem by switching to 2.88 MB media instead of 1.44 MB.
Clone Of:
: 853315 853319 (view as bug list)
Environment:
Last Closed: 2013-02-21 10:37:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0441 0 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2013-02-20 20:48:13 UTC

Description Mike Cao 2011-12-05 09:05:36 UTC
Description of problem:
check the virtio-win-XXX.vfd file , No netkvm drivers found for winXP Win& guest in vfd file ,It's better to add it 

Version-Release number of selected component (if applicable):
virtio-win-1.4.0-1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1.rpm -ivh virtio-win-1.4.0-1.el6.norach.rpm
2.mount -o loop /usr/share/virtio-win/virtio-win.vfd /opt
3.ll -t /opt/amd64/Win7
4.ll -t /usr/share/virtio-win/drivers/amd64/Win7
5.ll -t /opt/i386/Win7
6.ll -t /usr/share/virtio-win/drivers/i386/Win7
7.ll -t /opt/i386/WinXP
8.ll -t /usr/share/virtio-win/drivers/i386/WinXP
  
Actual results:
no netkvm related drivers in the directory listed above 

Expected results:
netkvm.cat netkvm.inf netkvm.sys should listed in the above directory 

Additional info:

Comment 2 Dor Laor 2012-05-01 11:55:16 UTC
Jay, can you commit the former 6.2 whqled driver to test it early before we get the 6.3 whql done?

Comment 5 Jay Greguske 2012-05-16 21:37:02 UTC
There is not enough space on the floppy image to provide drivers in these additional locations and vfat does not support links. I think this bug needs to be CLOSED->CANTFIX.

Filesystem           1K-blocks      Used Available Use% Mounted on
/tmp/whql-lzg6gs/virtio-win-1.5.1/virtio-win-1.5.1.vfd
                          1424      1395        29  98% /tmp/whql-lzg6gs/floppy

I built a new virtio-win without these changes that include the latest drivers signed by RH and MS:

https://brewweb.devel.redhat.com/buildinfo?buildID=214556

Comment 21 Jay Greguske 2012-08-09 15:12:51 UTC
It would be me since I build the VFD, but sounds like a non-starter until qemu-kvm supports it.

Comment 22 Ronen Hod 2012-08-12 08:12:55 UTC
Markus,

We would like to switch to 2.88 virtual floppy image. Does qemu support it?

Thanks, Ronen.

Comment 23 Markus Armbruster 2012-08-13 07:26:07 UTC
In theory, yes.  I'm not sure how much it's been used in practice, so I recommend to test it works for you.

Make sure to test both starting QEMU with an empty drive, and with a 2.88MiB medium in the drive.

Comment 25 Mike Cao 2012-08-13 07:54:29 UTC
cc'ing qzhang , I remember qzhang do some research on different kinds of floppy image support days ago ,

qzhang ,Could you try whether we support 2.88MB virtual floppy for windows guest ?

Thanks
Mike

Comment 28 Jay Greguske 2012-08-13 14:34:02 UTC
Here's a 2.88M VFD with the additional NetKVM drivers:

http://download.lab.bos.redhat.com/devel/jgregusk/share/virtio-win-1.5.4.vfd

Comment 29 Mike Cao 2012-08-14 05:54:55 UTC
(In reply to comment #28)
> Here's a 2.88M VFD with the additional NetKVM drivers:
> 
> http://download.lab.bos.redhat.com/devel/jgregusk/share/virtio-win-1.5.4.vfd

Thanks, Jay .
I tried it ,it works for winxp and win2k8-64 bit guests .

There is a bug for 2.88MB VFD file about formating ,but it does not block this bug .

Mike

Comment 30 Ronen Hod 2012-08-16 16:07:06 UTC
Great.
Mike, can we consider this bug fixed?

Comment 31 Mike Cao 2012-08-17 03:14:14 UTC
(In reply to comment #30)
> Great.
> Mike, can we consider this bug fixed?

Ronen ,Yes .

But there still no formal build , Jay only provide a scratch one . 
Change back to assigned status until the new 2.88MB vfd image build into the virtio-win release package .

Thanks,
Mike

Comment 32 Jay Greguske 2012-08-17 14:35:48 UTC
here's a real build:

https://brewweb.devel.redhat.com/buildinfo?buildID=229307

Comment 33 Yang Zhao 2012-08-24 07:20:51 UTC
Verify it with the real build virtio-win-1.5.4(https://brewweb.devel.redhat.com/buildinfo?buildID=229307).Checking the virtio-win-1.5.4.vfd file ,netkvm drivers have found for winXP/Win7 guest in vfd file.And it works well for winxp and win7 32/64 bit guests.Doing md5sum check between virtio-win-1.5.3.iso and virtio-win-1.5.4.vfd about the netkvm drivers,they both show the same values.

Based on above.this issue has been fixed.

Thanks,
Yang Zhao

Comment 34 Mike Cao 2012-08-24 07:22:47 UTC
According to comment #33 ,
move status to verified .

Comment 35 errata-xmlrpc 2013-02-21 10:37:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0441.html


Note You need to log in before you can comment on or make changes to this bug.