Bug 76005 - Bad Instruction Compiling glibc
Bad Instruction Compiling glibc
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
8.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-15 14:02 EDT by Need Real Name
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-15 22:16:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Second attempt to reproduce.. further along in make but same error (758 bytes, text/plain)
2002-10-15 22:16 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-10-15 14:02:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Was having a number of segmentation faults in npasswd and kylix, decided to
compile latest glibc libraries on suspicion glibc was culprit.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.untar glibc-2.3.1
2.configure with linuxthreads and /usr/local/gnu for path
3.make 
	

Actual Results:  In file included from ../sysdeps/ieee754/ldbl-96/strtold.c:43:
strtod.c: In function `__strtold_internal':
strtod.c:1566: internal error: Illegal instruction
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[1]: *** [strtold.o] Error 1
make[1]: Leaving directory `/linuxdat/tarballs/glibc-2.3.1/stdlib'
make: *** [stdlib/subdir_lib] Error 2
[root@linux glibc-2.3.1]#
[root@linux glibc-2.3.1]# find ./ -name strtod.c
./stdlib/strtod.c
[root@linux glibc-2.3.1]# cd ./stdlib/
[root@linux stdlib]# emacs strtod.c


Expected Results:  That I could build the package

Additional info:

Assume this is really a GNU problem but RedHat request for "bugzilla"
popped up. Si here it is. The real problem is "segfaults" will check Kylix site
for ideas.
Comment 1 Jakub Jelinek 2002-10-15 14:12:51 EDT
Is it reproduceable, always on the same file same error?
I'm building glibc very often and have not seen anything like this.
Comment 2 Need Real Name 2002-10-15 22:16:42 EDT
Created attachment 80604 [details]
Second attempt to reproduce.. further along in make but same error
Comment 3 Jakub Jelinek 2002-10-16 10:00:38 EDT
If it doesn't die on the same file all the time, it is most probably flaky
hardware. Check with memtest86 your memory etc.
Nothing to do with gcc.
gcc bug would be reproduceable always on the same file.

Note You need to log in before you can comment on or make changes to this bug.