Bug 760075 - Unable to update to caribou-0.4.1-2.fc16 while having both i686 and x86_64 versions installed
Summary: Unable to update to caribou-0.4.1-2.fc16 while having both i686 and x86_64 ve...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: caribou
Version: 16
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Parag Nemade
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-05 11:50 UTC by anymo_7
Modified: 2011-12-21 16:55 UTC (History)
1 user (show)

Fixed In Version: caribou-0.4.1-3.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-21 16:55:28 UTC
Type: ---


Attachments (Terms of Use)

Description anymo_7 2011-12-05 11:50:57 UTC
Description of problem:
Prior to version 0.4.1-2 both i686 and x86_64 versions were installed.
With the latest update, there appear to be some conflicts between the two.

Version-Release number of selected component (if applicable):
caribou-0.4.1-2.fc16.i686
caribou-0.4.1-2.fc16.x86_64

How reproducible:
On 64-bit Fedora 16 installations with both caribou.i686 and caribou.x86_64 installed.

Steps to Reproduce:
1. Install or update both i686 and x86_64 versions of caribou-0.4.1-2.

Actual results:
Conflicts between i686 and x86_64 versions.

Expected results:
Successful install/update of both packages.

Additional info:
Transaction Check Error:
  file /usr/bin/caribou from install of caribou-0.4.1-2.fc16.i686 conflicts with file from package caribou-0.4.1-2.fc16.x86_64
  file /usr/bin/caribou-preferences from install of caribou-0.4.1-2.fc16.i686 conflicts with file from package caribou-0.4.1-2.fc16.x86_64
  file /usr/lib/python2.7/site-packages/caribou/i18n.pyc from install of caribou-0.4.1-2.fc16.i686 conflicts with file from package caribou-0.4.1-2.fc16.x86_64
  file /usr/lib/python2.7/site-packages/caribou/i18n.pyo from install of caribou-0.4.1-2.fc16.i686 conflicts with file from package caribou-0.4.1-2.fc16.x86_64
  file /usr/libexec/antler-keyboard from install of caribou-0.4.1-2.fc16.i686 conflicts with file from package caribou-0.4.1-2.fc16.x86_64

Comment 1 Parag Nemade 2011-12-06 05:32:35 UTC
How can you have both the version installed on x86_64 machine? People are reporting that on 64 bit machine they are getting only i686 rpm and to resolve this they manually removed i686 rpm and installed x86_64 rpm. 

I believe due to some problem in either rpm or yum, caribou when moved from noarch to arch, on 64 bit installation getting only 32bit rpm installed.

I see that you are right. Last update missed to test the case when caribou.x86_64 is updated then whether caribou.i686 will also get updated successfully or not?

But if you have only 64 bit rpm then update is working fine.

Comment 2 anymo_7 2011-12-06 22:19:46 UTC
(In reply to comment #1)
> How can you have both the version installed on x86_64 machine? People are
> reporting that on 64 bit machine they are getting only i686 rpm and to resolve
> this they manually removed i686 rpm and installed x86_64 rpm. 
> 
> I believe due to some problem in either rpm or yum, caribou when moved from
> noarch to arch, on 64 bit installation getting only 32bit rpm installed.
> 
> I see that you are right. Last update missed to test the case when
> caribou.x86_64 is updated then whether caribou.i686 will also get updated
> successfully or not?
> 

After looking through my yum history I can confirm that noarch got updated to i686. However, x86_64 got pulled in as a dependency when I reinstalled gnome-shell. I don't remember why I had to do that, but that's when caribou.x86_64 appeared on my system.

> But if you have only 64 bit rpm then update is working fine.

Indeed it is, which is why I removed the i686 package. I tend to agree with you that having them both installed is a bit unusual and probably a very rare occurrence.

Comment 3 Parag Nemade 2011-12-07 03:53:57 UTC
I have created a new update that will resolve multilib issue. I have not split the caribou package into -antler, -gtk2-module, -gtk3-module and -common subpackages.

Please test the new update by adding repo into your system
http://repos.fedorapeople.org/repos/paragn/caribou/fedora-caribou.repo

you can now install both the arch rpms on your x86_64 system.

Comment 4 anymo_7 2011-12-07 11:15:26 UTC
(In reply to comment #3)
> I have created a new update that will resolve multilib issue. I have not split
> the caribou package into -antler, -gtk2-module, -gtk3-module and -common
> subpackages.
> 
> Please test the new update by adding repo into your system
> http://repos.fedorapeople.org/repos/paragn/caribou/fedora-caribou.repo
> 
> you can now install both the arch rpms on your x86_64 system.

The update seems to be working now, with both i686 and x86_64 packages installed.

As a side note, is the caribou package from your repo supposed to pull in the -antler, -common, -gtk2-module, and -gtk3-module as dependencies? I'm asking because it didn't, so I had to install them manually as can be seen from yum history output below.

Command Line   : install caribou.i686 caribou.x86_64
Packages Altered:
    Updated caribou-0.4.1-2.fc16.x86_64 @?updates
    Install caribou-0.4.1-3.fc16.i686   @fedora-caribou
    Update  caribou-0.4.1-3.fc16.x86_64 @fedora-caribou

Command Line   : install caribou*.i686 caribou*.x86_64 --exclude caribou-devel
Packages Altered:
    Install caribou-antler-0.4.1-3.fc16.i686        @fedora-caribou
    Install caribou-antler-0.4.1-3.fc16.x86_64      @fedora-caribou
    Install caribou-gtk2-module-0.4.1-3.fc16.i686   @fedora-caribou
    Install caribou-gtk2-module-0.4.1-3.fc16.x86_64 @fedora-caribou
    Install caribou-gtk3-module-0.4.1-3.fc16.i686   @fedora-caribou
    Install caribou-gtk3-module-0.4.1-3.fc16.x86_64 @fedora-caribou

Comment 5 Parag Nemade 2011-12-08 04:08:16 UTC
For me its like this where i was having only caribou-0.4.1-2.fc16 installed

Command Line   : update caribou
Packages Altered:
    Updated    caribou-0.4.1-2.fc16.x86_64             @?updates
    Obsoleted  caribou-0.4.1-2.fc16.x86_64             @?updates
    Update     caribou-0.4.1-3.fc16.x86_64             @fedora-caribou
    Obsoleting caribou-antler-0.4.1-3.fc16.x86_64      @fedora-caribou
    Obsoleting caribou-common-0.4.1-3.fc16.noarch      @fedora-caribou
    Obsoleting caribou-gtk2-module-0.4.1-3.fc16.x86_64 @fedora-caribou
    Obsoleting caribou-gtk3-module-0.4.1-3.fc16.x86_64 @fedora-caribou


I see your command line says install that mean you was having no caribou installed at all.

To reproduce this I removed caribou and use the same command like you did

Command Line   : install caribou.i686 caribou.x86_64
Packages Altered:
    Install caribou-0.4.1-3.fc16.i686   @fedora-caribou
    Install caribou-0.4.1-3.fc16.x86_64 @fedora-caribou


So it looks to me that caribou upgrade problem is fixed now. Thanks for testing this update.

Comment 6 Fedora Update System 2011-12-12 03:05:23 UTC
caribou-0.4.1-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/caribou-0.4.1-3.fc16

Comment 7 Fedora Update System 2011-12-12 22:06:47 UTC
Package caribou-0.4.1-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing caribou-0.4.1-3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-17041/caribou-0.4.1-3.fc16
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2011-12-21 16:55:28 UTC
caribou-0.4.1-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.