Bug 760078 - Failed to import "Process" resource
Failed to import "Process" resource
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Inventory (Show other bugs)
4.2
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: jon30-sprint10/rhq43-sprint10
  Show dependency treegraph
 
Reported: 2011-12-05 06:57 EST by vlad crc
Modified: 2012-01-18 04:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-18 04:24:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
exception stacktrace in log file (10.72 KB, application/octet-stream)
2011-12-05 06:57 EST, vlad crc
no flags Details

  None (edit)
Description vlad crc 2011-12-05 06:57:06 EST
Created attachment 540817 [details]
exception stacktrace in log file

Description of problem:
I try to import a resource of type "Process", just like in this demo:
http://www.rhq-project.org/display/JOPR2/Demo-ProcessMonitoring
but I get the error: "Failed to manually import resource".


Version-Release number of selected component:
4.2


How reproducible:
RHQ server 4.2 is running on an Linux system, the monitored JBoss 4.2.3 and the RHQ agent are running on another Linux box.


Steps to Reproduce:
1. Go to "Inventory", select a platform, right-click on the platform.
2. Select "Import" -> "Process", "Resource import wizard" opens.
3. For "Type" select "Process query".
4. For "Piql" uncheck the "Unset?" check-box and in "Value" field enter this:
         process|basename|match=.*java.*,arg|*|match=org.jboss.Main
5. Click "Finish" button.
  

Actual results:
On the top banner I got an error message saying: "Failed to manually import resource".
In RHQ server log I have the error attached.


Expected results:
The process resource should be successfully imported and it should appear in inventory.
Comment 1 Jay Shaughnessy 2012-01-17 10:11:11 EST
These steps worked fine for me on Windows. I also tried it with the agent
down, but that resulted in a different, and expected, connection exception.

I suggest someone try this
Comment 2 Jay Shaughnessy 2012-01-17 12:20:07 EST
... I just tried this on Linux and it worked for me again.

So, I can't repro this.  Perhaps the agent was running as a user unable
to perform the process query?

Setting back to NEW
Comment 3 vlad crc 2012-01-18 04:24:24 EST
My bad, my test cases were wrong. I close the bug. Sorry for trouble...

Note You need to log in before you can comment on or make changes to this bug.