This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 76016 - Wrong icon and label name
Wrong icon and label name
Status: CLOSED CURRENTRELEASE
Product: Red Hat Developer Suite
Classification: Retired
Component: eclipse (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Tromey
Tom Tromey
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-15 15:48 EDT by Need Real Name
Modified: 2014-08-11 01:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-24 17:05:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-15 15:48:52 EDT
Go to New->Project->Select C in the New Project Dialog.
In the right pane, the second option has a C++ icon beside it and the label is
"%SimpletoCStdMakeConversionWizard.name%". 
I think the icon should be a "C" icon, and the label should be "Simple to C".
Why is the label so complicated?

The same goes for the 2nd and 3rd labels in the right pane if C++ is selected in
the left pane. Also, the icon for the 2nd option here should show "C++" not "C".
Comment 1 Tom Tromey 2002-11-11 19:00:46 EST
This appears to be fixed with Andrew's latest import
Comment 2 Need Real Name 2002-11-12 11:29:17 EST
The labels are changed but the icons are the same. Also if you notice now, the
wizard name has changed so that under C++ projects, there are two wizards both
called "Convert to C++" and there seems to be no indication which is the C to
C++ and which is the Simple to C++ one. The one I know is supposed to be the C
to C++ has a C icon beside it (maybe is supposed to be the indication) but the
other one has a C++ icon, which doesn't indicate in any way that it converts
from a simple to a C++ project. 

This is the same as Bug #25889 on eclipse.org.
Comment 3 Need Real Name 2002-11-22 15:38:06 EST
It looks good now except the icon for Convert to C/C++ Project under the C
projects list. It is a C++ icon. I'm not sure if this is how its meant to be,
but if that is ok, then this bug is fixed.
Comment 4 Jeremy Handcock 2003-07-24 17:05:02 EDT
The new project dialog is still confusing, but this specific problem has since
been resolved.  Closing.

Note You need to log in before you can comment on or make changes to this bug.