This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 760209 - Drift Carousel not filtering the drift entries
Drift Carousel not filtering the drift entries
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: drift (Show other bugs)
4.2
All All
medium Severity medium (vote)
: ---
: ---,RHQ 4.3.0
Assigned To: Jay Shaughnessy
Mike Foley
:
Depends On:
Blocks: 707225 jon30-sprint10/rhq43-sprint10
  Show dependency treegraph
 
Reported: 2011-12-05 11:20 EST by Jay Shaughnessy
Modified: 2012-03-21 15:55 EDT (History)
0 users

See Also:
Fixed In Version: 4.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-21 15:55:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jay Shaughnessy 2011-12-05 11:20:51 EST
1) Generate some drift snapshots with various types of drift (file
added/removed/changed).

2) Go to the carousel view

3) apply a category filter

Note that the snapshots presented have been filtered to include
only the snapshots with the requested categories of drift. But,
the list of drift instances have not been filtered.  For example,
if you are looking for only file removed drift you get only snapshots
with removed files, but the list in those snapshot carousel members
is not limited to only the file-removed drift.
Comment 1 Jay Shaughnessy 2011-12-06 12:12:20 EST
master commit 32e06f0466e3a6a440518c4bd72e21c012bd6afa

I think this broke when initial criteria handling changed in the
underlying Table implementation.  The initial criteria was set correctly
but that was no longer applied directly to the grid, instead we now
manually perform the initial fetch. But that led to an overriden method
getting called to return the current criteria, which had yet to be
determined (it was thought to be needed on refresh only). So, the fix was
to immediately set the current criteria to the initial criteria in the
subclass.
Comment 2 Mike Foley 2011-12-12 10:50:19 EST
 i think i am seeing some incorrect behavior
like this
snapshot #2 has drift of these types:  file added, file removed
snapshot #1 has drift of this type:  file changed
when i twiddle the filtering ... to show file changed ... it shows that drift
but then when i retoggle the filter for file added and file removed ... that drift doesnt show again ... 
even though the snapshot range is 1-4.  it looks the snapshot range changes somehow ... to only focus on snapshot #1.

do you mind looking at this again?
Comment 3 Jay Shaughnessy 2011-12-15 17:59:04 EST
When you filter snapshots that don't include the drift you're looking for
go away by design.  Only the relevant snapshots remain.  Also, for those
remaining snapshots only the relevant drift remains.

Your first filter resulted in snapshot 1 only, so that became the
starting snapshot, which is itself a filter.  If it remains at 1
then higher snapshots will not be found, regardless of the other filters.

Is that what happened?  If so, what would you have preferred?
Comment 4 Mike Foley 2012-03-21 15:55:37 EDT
yes, what you describe is what happened.

not sure ... i guess i just got confused on expected behavior.

discussed with jay.  works as expected.

Note You need to log in before you can comment on or make changes to this bug.