Bug 76026 - The E1000 driver doesn't compile into the kernel
The E1000 driver doesn't compile into the kernel
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-15 17:34 EDT by Samuel Flory
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-08 18:22:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Samuel Flory 2002-10-15 17:34:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
  You can't compile the e1000 driver directly into the kernel.  This makes
netbooting difficult on system with the e1000 controller.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.set CONFIG_NET_E1000 to y
2.make clean dep bzimage
3.watch it break
	

Additional info:

This adapted from 2.4.20pre it works for me.

*** Makefile.old        2002-10-15 14:21:59.000000000 -0700
--- Makefile    2002-10-15 14:21:59.000000000 -0700
***************
*** 75,87 ****
  # Makefile for the Intel(R) PRO/1000 ethernet driver
  #
  
! obj-$(CONFIG_NET_E1000) += e1000.o
! 
! e1000-objs := e1000_main.o e1000_hw.o e1000_ethtool.o e1000_param.o \
!             e1000_proc.o
  
  include $(TOPDIR)/Rules.make
  
- e1000.o: $(e1000-objs)
-       $(LD) -r -o $@ $(e1000-objs)
  
--- 75,86 ----
  # Makefile for the Intel(R) PRO/1000 ethernet driver
  #
  
!  O_TARGET := e1000.o
!   
!  obj-y := e1000_main.o e1000_hw.o e1000_ethtool.o e1000_param.o \
!           e1000_proc.o
!  obj-m := $(O_TARGET)
  
  include $(TOPDIR)/Rules.make
Comment 1 Samuel Flory 2003-05-08 18:22:45 EDT
  This is not an issues in the current eratta kernels.

Note You need to log in before you can comment on or make changes to this bug.