Bug 760389 - [abrt] ccsm-0.9.5.92-1.fc16: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
[abrt] ccsm-0.9.5.92-1.fc16: Process /usr/bin/python was killed by signal 11 ...
Status: CLOSED DUPLICATE of bug 753067
Product: Fedora
Classification: Fedora
Component: ccsm (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
abrt_hash:790168edc6b9b059f2c622f2de8...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-05 21:21 EST by Stuart D Gathman
Modified: 2011-12-18 20:38 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-18 20:38:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (11.35 KB, text/plain)
2011-12-05 21:21 EST, Stuart D Gathman
no flags Details
File: build_ids (4.92 KB, text/plain)
2011-12-05 21:21 EST, Stuart D Gathman
no flags Details
File: smolt_data (2.71 KB, text/plain)
2011-12-05 21:21 EST, Stuart D Gathman
no flags Details
File: maps (29.84 KB, text/plain)
2011-12-05 21:21 EST, Stuart D Gathman
no flags Details
File: backtrace (76.05 KB, text/plain)
2011-12-05 21:21 EST, Stuart D Gathman
no flags Details

  None (edit)
Description Stuart D Gathman 2011-12-05 21:21:38 EST
libreport version: 2.0.7
abrt_version:   2.0.6
backtrace_rating: 4
cmdline:        /usr/bin/python /usr/bin/ccsm
comment:        Enabled Desktop Cube
crash_function: __pyx_f_12compizconfig_GetType
executable:     /usr/bin/python
kernel:         3.1.2-1.fc16.i686
pid:            20083
pwd:            /home/stuart
reason:         Process /usr/bin/python was killed by signal 11 (SIGSEGV)
time:           Mon 05 Dec 2011 09:16:51 PM EST
uid:            902
username:       stuart

backtrace:      Text file, 77871 bytes
build_ids:      Text file, 5043 bytes
dso_list:       Text file, 11624 bytes
maps:           Text file, 30561 bytes
smolt_data:     Text file, 2773 bytes

environ:
:XDG_VTNR=2
:XDG_SESSION_ID=502
:SSH_AGENT_PID=19695
:HOSTNAME=melissa.gathman.org
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:TERM=dumb
:SHELL=/bin/bash
:HISTSIZE=1000
:XDG_SESSION_COOKIE=fb337b923f8ec155953b333000000010-1323137565.882997-207191781
:GNOME_KEYRING_CONTROL=/tmp/keyring-ii5brD
:IMSETTINGS_MODULE=none
:USER=stuart
:SSH_AUTH_SOCK=/tmp/keyring-ii5brD/ssh
:USERNAME=stuart
:MAIL=/var/spool/mail/stuart
:DESKTOP_SESSION=compiz-gnome
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/stuart/bin
:QT_IM_MODULE=xim
:PWD=/home/stuart
:XMODIFIERS=@im=none
:LANG=en_US.UTF-8
:GNOME_KEYRING_PID=19547
:GDM_LANG=en_US.UTF-8
:GDMSESSION=compiz-gnome
:HISTCONTROL=ignoredups
:SHLVL=1
:XDG_SEAT=seat0
:HOME=/home/stuart
:LOGNAME=stuart
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-nvXjctL0Wj,guid=0b16c2c7cde84be9c48304da0003df56
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=2
:DISPLAY=:0.0
:XDG_RUNTIME_DIR=/run/user/stuart
:XAUTHORITY=/var/run/gdm/auth-for-stuart-qYi2YN/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/19553,unix/unix:/tmp/.ICE-unix/19553
:GPG_AGENT_INFO=/tmp/keyring-ii5brD/gpg:0:1
:DESKTOP_STARTUP_ID=gnome-panel-19749-melissa.gathman.org-ccsm-3_TIME254002121
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/fedora-ccsm.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=20083

var_log_messages:
:Dec  4 18:51:34 melissa yum[15428]: Installed: gnome-python2-rsvg-2.32.0-5.fc16.i686
:Dec  5 21:16:52 melissa abrt[20085]: Saved core dump of pid 20083 (/usr/bin/python) to /var/spool/abrt/ccpp-2011-12-05-21:16:51-20083 (12619776 bytes)

xsession_errors:
:/usr/lib/python2.7/site-packages/ccm/Window.py:92: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Window.py:95: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Widgets.py:1570: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Widgets.py:1575: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Window.py:92: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Window.py:95: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Widgets.py:1570: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Widgets.py:1575: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Window.py:92: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Window.py:95: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Widgets.py:1570: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
:/usr/lib/python2.7/site-packages/ccm/Widgets.py:1575: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
Comment 1 Stuart D Gathman 2011-12-05 21:21:42 EST
Created attachment 541140 [details]
File: dso_list
Comment 2 Stuart D Gathman 2011-12-05 21:21:46 EST
Created attachment 541141 [details]
File: build_ids
Comment 3 Stuart D Gathman 2011-12-05 21:21:48 EST
Created attachment 541142 [details]
File: smolt_data
Comment 4 Stuart D Gathman 2011-12-05 21:21:52 EST
Created attachment 541143 [details]
File: maps
Comment 5 Stuart D Gathman 2011-12-05 21:21:55 EST
Created attachment 541144 [details]
File: backtrace
Comment 6 Stuart D Gathman 2011-12-11 18:19:50 EST
After ccsm crashes, it leaves the config in a state where compiz no longer works well.  Is there any way to return compiz config to the default?  The default was at least usable.
Comment 7 Stuart D Gathman 2011-12-12 13:19:03 EST
I tried ccsm in gnome3 (in fallback mode), and it didn't crash.  I set desktop cube, logged out, and back with gnome2+compiz, and the cube was active.  I logged out and back with gnome3, to try another setting, but it crashed again.

I also notice that the workspace switcher does not track windows in gnome2+compiz.
Comment 8 Stuart D Gathman 2011-12-18 20:38:16 EST

*** This bug has been marked as a duplicate of bug 753067 ***

Note You need to log in before you can comment on or make changes to this bug.