Bug 76042 - File manager crashes when trying to play audio files
File manager crashes when trying to play audio files
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kdemultimedia (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-15 21:14 EDT by Dan Clowater
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-16 17:15:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Clowater 2002-10-15 21:14:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
7.3 worked just fine, then after upgradint to 8.0 I can no longer play mp3s or
any other audio file.  When I try clicking on it in the filemanager under
KDE3.0.3 or whatever the one is that shipped with 8.0, the filemanager crashes.
 XMMs, nor any of the other audio programs will play audio either.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Open directory with audio files
2.click on file
3.thing go boom ;)
	

Actual Results:  I get the Konqueror Crash agent telling me that incase I had
not noticed, what you just did sent a signal 11 (SIGSEGV) and quit.

Expected Results:  Upon clicking I should have heard beautiful music, but alas not.

Additional info:

BACKTRACE:

(no debugging symbols found)...[New Thread 8192 (LWP 1352)]
0x420ae169 in wait4 () from /lib/i686/libc.so.6
#0  0x420ae169 in wait4 () from /lib/i686/libc.so.6
#1  0x4212a2d0 in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x40e15c63 in waitpid () from /lib/i686/libpthread.so.0
#3  0x406261a5 in KCrash::defaultCrashHandler(int) ()
   from /usr/lib/libkdecore.so.4
#4  <signal handler called>
#5  0x408e7d67 in QObject::connect(QObject const*, char const*, QObject const*,
char const*) () from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#6  0x4063c2f3 in KLibrary::slotObjectCreated(QObject*) ()
   from /usr/lib/libkdecore.so.4
#7  0x4063dda6 in KLibrary::qt_invoke(int, QUObject*) ()
   from /usr/lib/libkdecore.so.4
#8  0x408e8d6b in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#9  0x4063e272 in KLibFactory::objectCreated(QObject*) ()
   from /usr/lib/libkdecore.so.4
#10 0x4007b941 in KParts::Factory::createPart(QWidget*, char const*, QObject*,
char const*, char const*, QStringList const&) () from /usr/lib/libkparts.so.2
#11 0x4131f343 in KonqViewFactory::create(QWidget*, char const*, QObject*, char
const*) () from /usr/lib/konqueror.so
#12 0x4131432f in KonqFrame::attach(KonqViewFactory const&) ()
   from /usr/lib/konqueror.so
#13 0x41307af7 in KonqView::switchView(KonqViewFactory&) ()
   from /usr/lib/konqueror.so
#14 0x41307fd0 in KonqView::changeViewMode(QString const&, QString const&) ()
   from /usr/lib/konqueror.so
#15 0x412e64a5 in KonqMainWindow::openView(QString, KURL const&, KonqView*,
KonqOpenURLRequest) () from /usr/lib/konqueror.so
#16 0x412e5960 in KonqMainWindow::openURL(KonqView*, KURL const&, QString
const&, KonqOpenURLRequest const&, bool) () from /usr/lib/konqueror.so
#17 0x412e7913 in KonqMainWindow::openURL(KonqView*, KURL const&,
KParts::URLArgs const&) () from /usr/lib/konqueror.so
#18 0x412e74c3 in KonqMainWindow::slotOpenURLRequest(KURL const&,
KParts::URLArgs const&) () from /usr/lib/konqueror.so
#19 0x412ffac6 in KonqMainWindow::qt_invoke(int, QUObject*) ()
   from /usr/lib/konqueror.so
#20 0x408e8d6b in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#21 0x4007a637 in KParts::BrowserExtension::openURLRequestDelayed(KURL const&,
KParts::URLArgs const&) () from /usr/lib/libkparts.so.2
#22 0x400794c0 in KParts::BrowserExtension::slotEmitOpenURLRequestDelayed() ()
   from /usr/lib/libkparts.so.2
#23 0x4007b1ba in KParts::BrowserExtension::qt_invoke(int, QUObject*) ()
   from /usr/lib/libkparts.so.2
#24 0x41f08d88 in IconViewBrowserExtension::qt_invoke(int, QUObject*) ()
   from /usr/lib/kde3/konq_iconview.so
#25 0x408e8d6b in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#26 0x40baf9f2 in QSignal::signal(QVariant const&) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#27 0x40902298 in QSignal::activate() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#28 0x40909933 in QSingleShotTimer::event(QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#29 0x40894c49 in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#30 0x408944f1 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#31 0x405ba9a6 in KApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libkdecore.so.4
#32 0x40837a88 in qt_activate_timers() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#33 0x40835330 in QApplication::processNextEvent(bool) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#34 0x40896280 in QApplication::enter_loop() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#35 0x4083502d in QApplication::exec() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#36 0x412df5e7 in main () from /usr/lib/konqueror.so
#37 0x0804cb9f in strcpy ()
#38 0x0804d8bb in strcpy ()
#39 0x0804ddd4 in strcpy ()
#40 0x0804eb40 in strcpy ()
#41 0x420158d4 in __libc_start_main () from /lib/i686/libc.so.6
Comment 1 Ngo Than 2002-10-16 11:10:20 EDT
It's fixed in 3.0.4-1 or newer. You will find in the next rawhide release.
Many thanks for your bug report.
Comment 2 Dan Clowater 2002-10-16 14:28:36 EDT
Nope - that's not true - I updated to the latest and it brings the mp3 player
thingmie into the file manager, but will not play audio files that are not
embedded into an application.
Comment 3 Ngo Than 2002-10-16 16:49:47 EDT
The problem is that the support of mp3 format has been removed in RHL 8.0
(license issue).

Please read the RHL 8.0 README in the Handbook.
Comment 4 Dan Clowater 2002-10-16 17:15:30 EDT
Well if I could find it I would read it... what do you mean mp3 format has been
removed???  You remove the most widely used audio file format from the latest
version of the OS?!?  What is the sense in this?  It defeats the purpose of
having RHL as an alternative OS if it is so second rate when it comes to every
day things...

As an aside - no audio file will play - wav, au, aiff, mp3, etc.

What is the resolution to this severe oversight???
Comment 5 Ngo Than 2002-10-16 17:32:25 EDT
I mean, the support of MPEG audio file (mp3) has been removed in 8.0. There is
no media player in the 8.0 which can play mp3 file!

I'm very unhappy with this issue, but we have to move it because of mp3 license.

The audio file wav, au, ogg are supported in 8.0.

Note You need to log in before you can comment on or make changes to this bug.