Bug 760437 - Mouse Logitech G300 compability
Mouse Logitech G300 compability
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
16
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-06 03:03 EST by Vitaly
Modified: 2013-04-29 03:54 EDT (History)
3 users (show)

See Also:
Fixed In Version: xorg-x11-drv-evdev-2.6.99.901-7.20120118git9d9c9870c.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-28 15:58:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vitaly 2011-12-06 03:03:46 EST
Description of problem:

The Logitech G300 mouse is a gaming mouse that includes programmable buttons. When first installed it is recognised and appears to work. However the left mouse click appears to move the mouse to the top left hand corner of the screen and perform a drag operation. Multiple left mouse clicks causes unexpected behaviour. This also affects drag actions with the left mouse button.

Using xinput list, the mouse is reported under Virtual core keyboard. Disabling the G300 as a keyboard input fixes the problem and the mouse behaves correctly.



Version-Release number of selected component (if applicable):

Fedora 16

How reproducible:

Every time after connect mouse Logitech G300 to Fedora 16. The mouse is totally unusable. 

Steps to Reproduce:
1. Connect mouse to F16
2. Verify pointer/click behavior with KDE or Gnome.
  
Actual results:

Unexpected mouse pointer behavior

Expected results:

As mouse is intended

Additional info:

I tried Logitech G300 mouse with latest distro Arch linux + Gnome, and got the same problem.

There is only workaround exist:
https://wiki.archlinux.org/index.php/Logitech_G300

Thanks,
Comment 1 Vitaly 2012-01-18 02:22:35 EST
This bug should be fixed with patch:

    Force x/y axes to exist on devices with any other axes (#44655)

I will able to check as soon as patch is pushed/released for FC16.

Best regards,
Vitaly.
Comment 2 Fedora Update System 2012-01-19 00:33:26 EST
xorg-x11-drv-evdev-2.6.99.901-5.20120118git9d9c9870c.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2012-0672/xorg-x11-drv-evdev-2.6.99.901-5.20120118git9d9c9870c.fc16
Comment 3 Vitaly 2012-01-19 07:16:17 EST
With this release my issue with Logitech G300 is fixed and it is working properly.
Comment 4 Fedora Update System 2012-01-25 01:32:50 EST
xorg-x11-drv-evdev-2.6.99.901-7.20120118git9d9c9870c.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/xorg-x11-drv-evdev-2.6.99.901-7.20120118git9d9c9870c.fc16
Comment 5 Fedora Update System 2012-01-25 17:30:10 EST
Package xorg-x11-drv-evdev-2.6.99.901-7.20120118git9d9c9870c.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-drv-evdev-2.6.99.901-7.20120118git9d9c9870c.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0928/xorg-x11-drv-evdev-2.6.99.901-7.20120118git9d9c9870c.fc16
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-01-28 15:58:08 EST
xorg-x11-drv-evdev-2.6.99.901-7.20120118git9d9c9870c.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.