Bug 76050 - KDE File Associatons With htmlview Downloads URL Contents Locally
KDE File Associatons With htmlview Downloads URL Contents Locally
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: htmlview (Show other bugs)
8.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-16 03:15 EDT by Thomas Smith
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-25 03:33:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas Smith 2002-10-16 03:15:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
I realize that htmlview is perhaps not at fault here, but I do not know where
else to put this bug report and it directly involves htmlview, even if it is
perhaps /usr/share/applications/redhat-web.desktop or some actor in between that
is the culprit.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Go to KDE Control Center, File Browsing, File Associatons
2. Add new association
3. Select the Internet, Web Browser entry from resulting dialog
4. Move this new association to top
5. Go to a KDE program (e.g. KMail)
6. Click on URL
7. Wait
8. Notice that Mozilla address bar shows link to local file at
.kde/share/apps/kfmexec/tmp/
9. Return to file assocations
10. Remove the Web Browser association
11. Add a new entry of "htmlview %u"
12. Repeat clicking on URL process in KDE app
13. Note that the URL is properly resolved now
	

Actual Results:  Adding a file association to the Internet - Web Browser from
the KDE menu (which launched Mozilla) causes any URLs to get a local file
download of the URL and thus not resolve correctly.

Expected Results:  Selecting the Internet - Web Browser when making the file
association should result in all URLs clicked on in KDE apps to properly resolve
with the browser normally called by clicking on Internet - Web Browser

Additional info:

Fixing this problem requires both a knowledge of what is actully behind the
scense of the Internet - Web Browser icon, tracking that down to determine that
htmlview is being called, and realizing that the %u parameter is necessary to
indicate the application can handle the remote  URL.  Inexperienced uses will
likely give up in frustration very early because their mental model is sound (I
click on this icon, so if I add it to the association, the URL will open normally).

Also, on my system, I have no /etc/conf/htmlview.conf or ~/htmlviewrc mentioned
elsewhere.  I tried creating an /etc/conf/htmlview.conf with a default of
Mozilla to see if that would resolve the poblem, but it did not.

Note You need to log in before you can comment on or make changes to this bug.