This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 76054 - Couldn't query for 'bash' bugs
Couldn't query for 'bash' bugs
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Test (Show other bugs)
2.17
i386 Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-16 06:06 EDT by Tim Waugh
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-17 05:18:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot showing working query (74.40 KB, image/png)
2002-10-16 19:22 EDT, David Lawrence
no flags Details

  None (edit)
Description Tim Waugh 2002-10-16 06:06:37 EDT
Description of Problem:
Software error while querying for open bash bugs.  I'd performed a query with
'bash' selected.

SELECT DISTINCT bugs.bug_id, bugs.remaining_time,
(SUM(ldtime.work_time)*COUNT(DISTINCT ldtime.bug_when)/COUNT(bugs.bug_id)) AS
actual_time, bugs.bug_severity, bugs.priority, bugs.rep_platform,
map_assigned_to.login_name, bugs.bug_status, bugs.resolution, bugs.short_desc
FROM profiles AS map_assigned_to, components components_, longdescs AS
ldtime,bugs LEFT JOIN bug_group_map ON bug_group_map.bug_id = bugs.bug_id AND
bug_group_map.group_id IS NULL LEFT JOIN cc ON cc.bug_id = bugs.bug_id WHERE
bugs.assigned_to = map_assigned_to.userid AND components_.id = bugs.component_id
AND ldtime.bug_id = bugs.bug_id AND bugs.component_id = components_.id AND
(components_.name = 'bash') AND (bugs.bug_status = 'NEW' OR bugs.bug_status =
'ASSIGNED' OR bugs.bug_status = 'REOPENED') AND (components_.name = 'bash') AND
((bug_group_map.group_id IS NULL) OR (bugs.reporter_accessible = 1 AND
bugs.reporter = 0) OR (bugs.cclist_accessible = 1 AND cc.who = 0) OR
(bugs.assigned_to = 0)) GROUP BY
bugs.bug_id,bugs.remaining_time,bugs.bug_severity,bugs.priority,bugs.rep_platform,map_assigned_to.login_name,bugs.bug_status,bugs.resolution,bugs.short_desc
ORDER BY map_components.name,bugs.bug_id : ERROR: Relation "map_components" does
not exist at globals.pl line 280.
Comment 1 David Lawrence 2002-10-16 14:57:19 EDT
Can you post the resulting URL string that is in the address window after
hitting the Search button on the query page? Is this a stored query that you are
executing? I cannot get this to fail on stock query.
Comment 3 David Lawrence 2002-10-16 19:21:28 EDT
I cannot seem to get this to fail for me. I have attached a screenshot showing
the resultant bug set.
Comment 4 David Lawrence 2002-10-16 19:22:31 EDT
Created attachment 80744 [details]
Screenshot showing working query
Comment 5 Tim Waugh 2002-10-17 05:18:34 EDT
Try it in galeon.  It works for me in mozilla and konqueror, now that I try them.
Comment 6 David Lawrence 2002-10-23 17:40:21 EDT
Should be fixed now. 

http://bugzilla.redhat.com/rh-bugzilla-beta3

Thanks

Note You need to log in before you can comment on or make changes to this bug.