Bug 760775 - "guestfish: multi-boot operating systems are not supported by the -i option" should be more explanatory
"guestfish: multi-boot operating systems are not supported by the -i option" ...
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-06 17:16 EST by Richard W.M. Jones
Modified: 2011-12-07 06:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-07 06:48:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2011-12-06 17:16:57 EST
Description of problem:

$ guestfish -a disk.img -i
guestfish: multi-boot operating systems are not supported by the -i option

It would be better if this offered some tips, such as removing
the -i option and using 'list-filesystems'.  We need to be
careful because the same message appears with tools like
virt-cat (and needs to be changed there too).

Version-Release number of selected component (if applicable):

1.15.9
Comment 1 Richard W.M. Jones 2011-12-07 06:48:00 EST
Fixed in commit 7d3848ddc046f79cc1112809bd9970eea8060018.

Updated messages:

$ ./run ./cat/virt-cat /tmp/test1.img /etc/passwd
virt-cat: no operating system was found on this disk

If using guestfish '-i' option, remove this option and instead
use the commands 'run' followed by 'list-filesystems'.
You can then mount filesystems you want by hand using the
'mount' or 'mount-ro' command.

If using guestmount '-i', remove this option and choose the
filesystem(s) you want to see by manually adding '-m' option(s).
Use 'virt-filesystems' to see what filesystems are available.

If using other virt tools, this disk image won't work
with these tools.  Use the guestfish equivalent commands
(see the virt tool manual page).

$ ./run ./cat/virt-cat -a ArchLinux -a F16x64 /etc/passwd
virt-cat: multi-boot operating systems are not supported

If using guestfish '-i' option, remove this option and instead
use the commands 'run' followed by 'list-filesystems'.
You can then mount filesystems you want by hand using the
'mount' or 'mount-ro' command.

If using guestmount '-i', remove this option and choose the
filesystem(s) you want to see by manually adding '-m' option(s).
Use 'virt-filesystems' to see what filesystems are available.

If using other virt tools, multi-boot operating systems won't work
with these tools.  Use the guestfish equivalent commands
(see the virt tool manual page).

Note You need to log in before you can comment on or make changes to this bug.