Bug 76078 - NFS install option ignores "discX" convention
NFS install option ignores "discX" convention
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-16 12:54 EDT by Michael Richardson
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-16 12:54:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Richardson 2002-10-16 12:54:52 EDT
Description of Problem:

The RPMS merging is annoying for a network install. Much easier if one can just
loopback mount the CDs and NFS export them. Certainly easier if you have three
CDroms, or a jukebox for them.!

Version-Release number of selected component (if applicable):


How Reproducible:

Do an NFS install from a server setup like:

cassidy-[/distros/redhat/8.0] mcr 1161 %ls -lL
total 1973822
drwxr-xr-x    6 root     root         6144 Sep 10 16:34 disc1/
drwxr-xr-x    3 root     root         2048 Sep 10 16:34 disc2/
drwxr-xr-x    4 root     root         2048 Sep 10 16:56 disc3/
-rw-r--r--    1 mcr      mcr      675315712 Oct 10 14:31 psyche-i386-disc1.iso
-rw-r--r--    1 mcr      mcr      666271744 Oct  9 16:46 psyche-i386-disc2.iso
-rw-r--r--    1 mcr      mcr      677609472 Oct  9 18:08 psyche-i386-disc3.iso
cassidy-[/distros/redhat/8.0] mcr 1163 %df | grep distros
/distros/redhat/7.2/enigma-i386-disc1.iso
                        662072    662072         0 100% /distros/redhat/7.2/disc
1
/distros/redhat/7.2/enigma-i386-disc2.iso
                        653740    653740         0 100% /distros/redhat/7.2/disc
2
/distros/redhat/8.0/psyche-i386-disc2.iso
                        650656    650656         0 100% /distros/redhat/8.0/disc
2
/distros/redhat/8.0/psyche-i386-disc1.iso
                        659488    659488         0 100% /distros/redhat/8.0/disc
1
/distros/redhat/8.0/psyche-i386-disc3.iso
                        661728    661728         0 100% /distros/redhat/8.0/disc
3


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:

It complains that /distros/redhat/8.0/ does not have a valid distribution.

Expected Results:

I expect it to see that there are disc1/disc2/disc3 in that dir, and then do
three more NFS mounts for them.
(You have to do the NFS mounts, because NFS does not cross mount points on the
host).
It would be nice if this worked for HTTP and FTP installs as well.

Additional Information:
	
The workaround is to copy the RedHat/base/ dir from disc1 up one level,
and build a symlink tree from Redhat/RPMS/* to disc?/RPMS/*, and then do the
mounts manually.

cassidy-[/distros/redhat/8.0] mcr 1216 %ls -l RedHat/RPMS/zsh-4.0.4-8.i386.rpm 
lrwxrwxrwx    1 mcr      mcr            44 Oct 16 12:32
RedHat/RPMS/zsh-4.0.4-8.i386.rpm -> ../../disc3/RedHat/RPMS/zsh-4.0.4-8.i386.rpm
cassidy-[/distros/redhat/8.0] mcr 1217 %cat domounts
#!/bin/sh

mount cassidy:/distros/redhat/8.0/disc1 /mnt/source/disc1
mount cassidy:/distros/redhat/8.0/disc2 /mnt/source/disc2
mount cassidy:/distros/redhat/8.0/disc3 /mnt/source/disc3


For mirrors, it would be convenient if they could just suck the ISO images,
loopback mount them, and be done. That would halve their disk space.
Comment 1 Jeremy Katz 2002-10-16 17:58:23 EDT
That's why we support just using the ISOs remotely for NFS.  Handling loopback
mounted ISOs on the server-side for NFS is much less convenient due to the way
NFS under Linux works.
Comment 2 Michael Richardson 2002-10-16 21:26:21 EDT
I don't see how it matters. Three mounts, as I show, does the trick.

If there is a better way, I would love to hear it.
cf the documentation please. It is not obvious to me, and I've been doing
network installs of OSes since SunOS 3.

Note You need to log in before you can comment on or make changes to this bug.