Bug 76081 - Pressing AltGr generates garbage
Pressing AltGr generates garbage
Status: CLOSED DUPLICATE of bug 71136
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-keyboard (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-16 13:30 EDT by Christian Rose
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-21 08:24:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Rose 2002-10-16 13:30:22 EDT
In 8.0, whenever I press AltGr on my (Swedish) keyboard (in order to compose
some other character such as @ by subsequently pressing another key), I seem to
get random garbage (such as 0, ", and unprintable characters), in addition to
the composed character I wanted.

Pressing *only* AltGr also generates the same garbage. This happens both in
console mode and in X. I can reproduce this on at least three machines.
Comment 1 Tim Waugh 2002-10-16 14:40:10 EDT
What does 'locale' say?
Comment 2 Christian Rose 2002-10-16 18:18:32 EDT
Output of "locale":

LANG=sv_SE.UTF-8
LC_CTYPE="sv_SE.UTF-8"
LC_NUMERIC="sv_SE.UTF-8"
LC_TIME="sv_SE.UTF-8"
LC_COLLATE="sv_SE.UTF-8"
LC_MONETARY="sv_SE.UTF-8"
LC_MESSAGES="sv_SE.UTF-8"
LC_PAPER="sv_SE.UTF-8"
LC_NAME="sv_SE.UTF-8"
LC_ADDRESS="sv_SE.UTF-8"
LC_TELEPHONE="sv_SE.UTF-8"
LC_MEASUREMENT="sv_SE.UTF-8"
LC_IDENTIFICATION="sv_SE.UTF-8"
LC_ALL=
Comment 3 Tim Waugh 2002-10-17 05:41:21 EDT
I don't see that here.  Please give me a detailed 'steps to reproduce'.  Thanks.
Comment 4 Christian Rose 2002-10-17 07:14:25 EDT
1) Install 8.0 system from scratch
2) Pick Swedish keyboard at the installation time
3) Use defaults in other settings

That should be it. On such a system, when I press AltGr only on the terminal, I
get 0, and in the GDM login box and other X applications I get ". When I press
AltGr in addition to a second dead key, I get the 0 or " garbage in addition to
the dead key character.

The contents of my /etc/sysconfig/i18n:
LANG="sv_SE.UTF-8"
SUPPORTED="en_US.UTF-8:en_US:en:de_DE.UTF-8:de_DE:de:sv_SE.UTF-8:sv_SE:sv"
SYSFONT="latarcyrheb-sun16"
Comment 5 Tim Waugh 2002-10-17 08:13:31 EDT
I still can't reproduce it, although I don't have a Swedish keyboard.  I tried
those steps (with a UK keyboard), and dead keys work fine.  For example, AltGr-[
a produces an a with an umlaut.

Since you see this in applications other than bash, it can't be a bash bug. 
Reassigning to redhat-config-keyboard.
Comment 6 Tim Waugh 2002-10-17 08:14:05 EDT
bfox: Can you reproduce this problem?
Comment 7 Gilles CHAUVIN 2002-10-21 08:18:30 EDT
This bug is a duplicate of:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=71136
and
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=74759

I got the same problem using RedHat Linux 7.1, 7.2 and 7.3 updated to the latest
kernel (2.4.18-17.7.x) using up2date. The keyboard layout used here is
"fr-latin1". Same problem too with RedHat 8.0.

Pressing the right Alt key (AltGr) prints "0" on the console. Under X AltGr
generates '"'.
Comment 8 Gilles CHAUVIN 2002-10-21 08:23:58 EDT
Oh I forgot, as nicolas(dot)mailhot(at)one2team(dot)com say at
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=74759 , this problem only
occurs when "NumLock" is on when working with the console. If NumLock is off, no
garbage characters are printed on the screen (with console).

When working with X, the '"' are still displayed whenever NumLock is on or not.
Comment 9 Tim Waugh 2002-10-21 08:27:32 EDT
Marking as duplicate.

*** This bug has been marked as a duplicate of 71136 ***

Note You need to log in before you can comment on or make changes to this bug.