This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 76086 - Softlink missing for libelf.so
Softlink missing for libelf.so
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: net-snmp (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-16 14:19 EDT by RLX Technologies
Modified: 2015-03-04 20:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-17 06:39:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description RLX Technologies 2002-10-16 14:19:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Softlink for /usr/lib/libelf.so is missing after installing RPM libelf-0.8.2-2
with RH 8.0.  This causes problems when building products with rpmbuild - such
as net-snmp-5.0.1-6.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Rebuild net-snmp-5.0.1-6 with rpmbuild
2.
3.
	

Actual Results:  Link Edit fails when -lelf used and softlink libelf.so does not
point to the real "so" (libelf.so.0.8.2).

Expected Results:  After the following commands - everything works:

cd /usr/lib
ln -s libelf.so.0.8.2 libelf.so

Additional info:

/usr/bin/ld: cannot find -lelf
collect2: ld returned 1 exit status
make[1]: *** [snmpd] Error 1
Comment 1 Jakub Jelinek 2002-10-16 15:02:51 EDT
The symlink is there, you just forgot to install libelf-devel.
Comment 2 RLX Technologies 2002-10-16 15:22:51 EDT
Or, you may mean that net-snmp-5.0.1-6 (others ?) needs a "BuildPrereq" change
to indicate a requirement that seems to be missing - for libelf-devel !!!
Comment 3 Need Real Name 2002-10-25 17:43:11 EDT
Spec missing Buildreq of libelf-devel.
Install libelf-devel from the CDROM, rpmfind.net or redhat.com.

After I installed that and added libelf-devel to the Buildreq in my spec file, 
this popped up just before the packages were rolled into rpms:

Checking for unpackaged file(s): /usr/lib/rpm/check-files /var/tmp/net-snmp-root
error: Installed (but unpackaged) file(s) found:
   /usr/bin/snmpcheck
   /usr/bin/tkmib
   /usr/share/man/man1/mib2c.1.gz
   /usr/share/man/man1/snmpconf.1.gz


RPM build errors:
    Installed (but unpackaged) file(s) found:
   /usr/bin/snmpcheck
   /usr/bin/tkmib
   /usr/share/man/man1/mib2c.1.gz
   /usr/share/man/man1/snmpconf.1.gz

I'm adding these files to the utils filelist in my spec and I'll let you know 
how that turns out after recompile.
Comment 4 Need Real Name 2002-10-25 19:08:01 EDT
Yep, that worked.  Here's a diff for your spec.  Have fun:

--- net-snmp.spec       2002-08-31 17:00:04.000000000 -0500
+++ net-snmp.spec.good  2002-10-25 16:44:31.000000000 -0500
@@ -1,7 +1,7 @@
 Summary: A collection of SNMP protocol tools and libraries.
 Name: net-snmp
 Version: 5.0.1
-Release: 6
+Release: 7
 License: BSDish
 Group: System Environment/Daemons
 Source0: ftp://net-snmp.sourceforge.net/net-snmp-%{version}.tar.gz
@@ -23,7 +23,7 @@
 Prereq: /sbin/chkconfig
 Obsoletes: ucd-snmp
 BuildRoot: %{_tmppath}/%{name}-root
-BuildPrereq: tcp_wrappers, openssl-devel
+BuildPrereq: tcp_wrappers, openssl-devel, libelf-devel
 
 %define __libtoolize /bin/true
 
@@ -184,6 +184,7 @@
 %{_bindir}/snmpbulkget
 %{_bindir}/snmpbulkwalk
 %{_bindir}/snmpconf
+%{_bindir}/snmpcheck
 %{_bindir}/snmpdelta
 %{_bindir}/snmpdf
 %{_bindir}/snmpget
@@ -199,10 +200,13 @@
 %{_bindir}/snmpusm
 %{_bindir}/snmpwalk
 %{_bindir}/snmpvacm
+%{_bindir}/tkmib
 %{_bindir}/traptoemail
+%attr(0644,root,root)  %{_mandir}/man1/mib2c.1*
 %attr(0644,root,root)  %{_mandir}/man1/snmpbulkwalk.1*
 %attr(0644,root,root)  %{_mandir}/man1/snmpbulkget.1*
 %attr(0644,root,root)  %{_mandir}/man1/snmpcmd.1*
+%attr(0644,root,root)  %{_mandir}/man1/snmpconf.1*
 %attr(0644,root,root)  %{_mandir}/man1/snmpdelta.1*
 %attr(0644,root,root)  %{_mandir}/man1/snmpdf.1*
 %attr(0644,root,root)  %{_mandir}/man1/snmpget.1*
@@ -230,6 +234,11 @@
 %attr(0644,root,root)  %{_mandir}/man3/*

Comment 5 Brent Nordquist 2002-12-06 21:40:57 EST
bzip2-devel is also required, and should be added to BuildPrereq.
Comment 6 Phil Knirsch 2002-12-17 06:39:07 EST
Fixed in net-snmp-5.0.6-9 rawhide build.

Note You need to log in before you can comment on or make changes to this bug.