Bug 76088 - No longer able to print from LPRng after switching spooler
No longer able to print from LPRng after switching spooler
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: cups (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-16 14:42 EDT by Gerry Kirk
Modified: 2011-12-28 02:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-09 11:33:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the file /etc/alchemist/namespaces/printconf/local.adl (492 bytes, application/octet-stream)
2002-10-16 14:45 EDT, Gerry Kirk
no flags Details

  None (edit)
Description Gerry Kirk 2002-10-16 14:42:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
I tried to switch to CUPS, but found I couldn't print. Tried following steps
given by Tim Waugh (twaugh@redhat.com) to get LPRng working again.:

redhat-switch-printer
service cups stop
chkconfig cups-lpd off
service xinetd reload
rm /etc/printcap
service lpd start

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Start redhat-switch-printer.
2. Select CUPS to switch from working LPRng system.
3. Apply changes.
4. Follow instructions on screen to restart CUPS. I also stopped the lpd daemon.

	

Actual Results:  unable to print, except from root.

Expected Results:  able to print

Additional info:

I was asked by Tim to attach my /etc/alchemist/namespace/printconf/local.adl file.
Comment 1 Gerry Kirk 2002-10-16 14:45:50 EDT
Created attachment 80705 [details]
This is the file /etc/alchemist/namespaces/printconf/local.adl
Comment 2 Ngo Than 2002-10-16 17:12:09 EDT
it's a bug in cups. I assign it to correct component
Comment 3 Tim Waugh 2002-10-16 18:22:01 EDT
I'm changing the title of this, since you decided to use LPRng.

Does 'alternatives --display print' show that the link points to lpr.LPRng now,
after using redhat-switch-printer?  If not, please re-run redhat-switch-printer
and look again.

(Than: we found that it wasn't before, which is why it was filed against
redhat-switch-printer.)
Comment 4 Gerry Kirk 2002-10-21 09:30:41 EDT
Here is the results of running `alternatives --display print`:

[root@giesbrecht root]# alternatives --display print
print - status is manual.
 link currently points to /usr/bin/lpr.LPRng
/usr/bin/lpr.cups - priority 20
 slave print-cancel: /usr/bin/cancel.cups
 slave print-lp: /usr/bin/lp.cups
 slave print-lpq: /usr/bin/lpq.cups
 slave print-lprm: /usr/bin/lprm.cups
 slave print-lpstat: /usr/bin/lpstat.cups
 slave print-lpc: /usr/sbin/lpc.cups
 slave print-cancelman: /usr/share/man/man1/cancel-cups.1.gz
 slave print-lpman: /usr/share/man/man1/lp-cups.1.gz
 slave print-lpqman: /usr/share/man/man1/lpq-cups.1.gz
 slave print-lprman: /usr/share/man/man1/lpr-cups.1.gz
 slave print-lprmman: /usr/share/man/man1/lprm-cups.1.gz
 slave print-lpstatman: /usr/share/man/man1/lpstat-cups.1.gz
 slave print-lpcman: /usr/share/man/man8/lpc-cups.8.gz
/usr/bin/lpr.LPRng - priority 30
 slave print-cancel: /usr/bin/cancel.LPRng
 slave print-lp: /usr/bin/lp.LPRng
 slave print-lpq: /usr/bin/lpq.LPRng
 slave print-lprm: /usr/bin/lprm.LPRng
 slave print-lpstat: /usr/bin/lpstat.LPRng
 slave print-lpc: /usr/sbin/lpc.LPRng
 slave print-cancelman: /usr/share/man/man1/cancel-LPRng.1.gz
 slave print-lpman: /usr/share/man/man1/lp-LPRng.1.gz
 slave print-lpqman: /usr/share/man/man1/lpq-LPRng.1.gz
 slave print-lprman: /usr/share/man/man1/lpr-LPRng.1.gz
 slave print-lprmman: /usr/share/man/man1/lprm-LPRng.1.gz
 slave print-lpstatman: /usr/share/man/man1/lpstat-LPRng.1.gz
 slave print-lpcman: /usr/share/man/man8/lpc-LPRng.8.gz
Current `best' version is /usr/bin/lpr.LPRng.
Comment 5 Tim Waugh 2004-12-09 11:33:23 EST
No longer supporting multiple spoolers.
Comment 6 Jeff Law 2011-12-28 00:32:03 EST
*** Bug 770132 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.