Bug 760903 - RFE: Load modules when configuration snippets are dropped into /etc/modules-load.d/
RFE: Load modules when configuration snippets are dropped into /etc/modules-l...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks: systemd-RFE
  Show dependency treegraph
 
Reported: 2011-12-07 05:23 EST by Jóhann B. Guðmundsson
Modified: 2014-06-19 19:04 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-19 19:04:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Path unit (395 bytes, text/plain)
2011-12-07 05:26 EST, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-12-07 05:23:49 EST
Description of problem:

Ok so packagers/maintainers fail to see the advantages of using load module configuration file as opposed to loading the module in the unit when it gets started since the module does not get loaded at install time which forces users to either restart the systemd-modules-load.service manually or do it via modprobe themselves or having to reboot. 

So I'm wondering if there is something that is preventing us using a path unit to do (re)start the service once an user/package creates/drops an configuration file into the /etc/modules-load.d/ directory? 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2011-12-07 05:26:22 EST
Created attachment 541818 [details]
Path unit

I guess something like this should work...
Comment 2 Jóhann B. Guðmundsson 2012-02-27 06:57:21 EST
Basically the issue here is that when you install a package that contains a load module the module does not get loaded thus users will have to reboot or manually load the module...
Comment 3 Lennart Poettering 2014-06-19 19:04:46 EDT
Hmm, so if at all, then the packaging scripts should load the modules after installation, but I feel very uncomfortable about that too.

I am really not convinced this is really a good idea, so far none of the systemd configuration files are automatically reread and activated, and it sounds wrong to me to start now here for this, especially as modules loading is a bit risky in many ways...

I really prefer if configuration files like this one are applied only when the user can assume they are. For example, when the user reboots the system, or when he installs packages, or when he explicitly invokes systemd-load-modules.service. But all of these are either already covered or can be handled from the respective packaging scripts explicitly (for example by invoking /usr/lib/systemd/systemd-modules-load from there), we don't need an automatism for that. And I am pretty sure we shouldn't act for these somewhat dangerous operations behind the users back, just because something starting placing files in the dir, and isn't even finished yet... I mean, we don't have transactions in the file systems in Linux. The next best thing we have is that user actions can imply them, such as booting/package installation/direct invocation. But just moving things around in the dir isn't that...

Really not convinced of this one, sorry.

Note You need to log in before you can comment on or make changes to this bug.