Bug 761055 - grubby defaults to grub2-efi.cfg instead of grub2.cfg
grubby defaults to grub2-efi.cfg instead of grub2.cfg
Status: CLOSED DUPLICATE of bug 732058
Product: Fedora
Classification: Fedora
Component: grubby (Show other bugs)
16
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-07 11:08 EST by Stefano Cavallari
Modified: 2011-12-09 05:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-09 05:58:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefano Cavallari 2011-12-07 11:08:11 EST
Description of problem:
grubby interacts with grub2-efi.cfg instead of grub2.cfg


Version-Release number of selected component (if applicable):
8.3-1

How reproducible:
Always

Steps to Reproduce:
1. Install fedora-16
2. Install grub2-efi *just the package*
3. run "grubby --info=ALL"
  
Actual results:
kernels from grub2-efi.cfg

Expected results:
kernels from grub2.cfg

Additional info:
looks like the problem is here (unverified)
http://git.fedorahosted.org/git?p=grubby.git;a=blob;f=grubby.c;h=f21a7f8969134bf49c6c91c1ab5747027872da2c;hb=f1e780b61fdf922b4d73b671c4c355650ee6e9fa#l207

I discovered this bug because pm-hibernate was not working as it uses grubby.
Comment 1 Mads Kiilerich 2011-12-08 14:11:23 EST
Grubby can operate on multiple kinds of boot loader configuration files. Like /sbin/new-kernel-pkg you will have to specify --grub2 -c /etc/grub2.cfg if you want that particular configuration file. Otherwise you will get the default.
Comment 2 Stefano Cavallari 2011-12-09 04:37:53 EST
Maybe the bug should be filed elsewhere, but still I don't understand what is the correct method in Fedora to understand the current bootloader.
Script /usr/lib64/pm-utils/sleep.d/01grub calls grubby with no explicit configuration file to modify.

Maybe the solution is to conflict grub2 vs grub2-efi, as installing both confuses grubby (or who assumes grubby is automagic enough).

Feel free to move this bug to pm-utils or whatever package it belongs.
Comment 3 Mads Kiilerich 2011-12-09 05:58:25 EST
The core issue of pm-utils / grub2 integration is tracked on bug 732058.

*** This bug has been marked as a duplicate of bug 732058 ***

Note You need to log in before you can comment on or make changes to this bug.