Bug 76106 - More PCI devices returned than exist, IRQ conflicts
More PCI devices returned than exist, IRQ conflicts
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2002-10-16 17:24 EDT by kevin long
Modified: 2008-08-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-30 11:40:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description kevin long 2002-10-16 17:24:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; T312461)

Description of problem:
lspci returns 3 x 3com 3c900 NIC. kernel returns "kernel: eth0: Interrupt 
posted  but not delivered -- IRQ blocked by another device? IRQ is 15 for eth0, 
same as CDROM. If CDROM is disabled, eth0 becomes disabled. 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install RH7.2, or 7.3 on an HP LH4, with any PCI adapters
2. Boot
3. Watch non-existent PCI devices get detected by Kudzu. Watch the modules fail 
to load into the kernel, as they don't exist.

Actual Results:  Networking performance grinds to a crawl. Errors re-occur 
every 5 seconds. Logs swell up hugely. Any additional PCI devices, such as SCSI 
adapters with TBU's attached will fail to load their modules.

Expected Results:  System worked great with 6.2, and 7.0.

Additional info:

I am sure it's related to the HP LH4 hardware, and possibly the HP smart IRQ 
router. Here's a kernel patch - 
pci_enable_device.patch that seems to imply this multiple device issue is 
specific to this model. An HP tech document suggests turning off the smart IRQ 
router, in an unrelated document for Windows 2000, when accessing IRQ 9. If I 
do "ifconfig eth1 down" (shutting down the 2nd NIC, eth0 also drops off the 
Comment 1 Arjan van de Ven 2002-10-16 17:31:07 EDT
if this is an UP system, could you try the SMP kernel?
if this is an SMP system, could you try passing "noapic" on the kernel command line?

(and that patch looks really really evil btw)
Comment 2 kevin long 2002-10-16 17:36:30 EDT
I have tried both SMP and UP kernels, in both 7.2, and am currently at 2.4.18-
10 on 7.3. I don't think I've tried passing apic to the kernel. I will do so.
Comment 3 kevin long 2002-10-24 15:21:20 EDT
I have just tested passing noapic on the command line to the kernel, and it 
made no difference at all. I have also changed HP IRQ routing from smart to 
fixed, in the BIOS, in case it was a related issue, and that has not made any 
difference either.
Comment 4 Bugzilla owner 2004-09-30 11:40:05 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.