Bug 76110 - RedHat KDE 3.0.3-13 changes breaks 3rd party kcontrol and kio plugins
RedHat KDE 3.0.3-13 changes breaks 3rd party kcontrol and kio plugins
Status: CLOSED DUPLICATE of bug 74071
Product: Red Hat Linux
Classification: Retired
Component: desktop-file-utils (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Ben Levenson
: Triaged
Depends On:
Blocks: 79579
  Show dependency treegraph
Reported: 2002-10-16 17:57 EDT by Need Real Name
Modified: 2007-04-18 12:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:49:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-16 17:57:19 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux) 
Description of problem: 
The changes made to KDE 3.0.3-13 breaks the ability of 3rd party kcontrol and 
kio plugins to work.  The addition of the kde- extension to all plugins such 
as kde-konghtml breaks the ability of kcmshell and kcontrol to locate and 
allow 3rd party modules to load.  The kcmshell --list command does not list 
any plugins that have been installed that were compatible with KDE from older 
RedHat 7.x versions.  The kdebase-3.0.3-dtfix patch contains the patches for 
the individual modules. 
Version-Release number of selected component (if applicable): 
How reproducible: 
Steps to Reproduce: 
1.  Compile or install a 3rd part kcontrol plugin (i.e. mosfet-liquid, ktalkd, 
etc.) In short, any plugins that are not from the RedHat KDE packages will 
fail to work properly. 
2.  Run kcmshell --list  (The newly installed module will not appear in the 
list because it was not compiled with the kde- prefix) 
3.  Run kcmshell <module>  (The module will fail to load and run) 
4.  Run kcontrol (No new kcontrol modules will appear in the module menus 
after installation) 
Expected Results:  The kcmshell ---list command should be able to find any 
modules that do not use the kde- prefix for their module name. 
Additional info:
Comment 1 Ngo Than 2002-10-16 19:32:05 EDT

i think it's a bug in desktop-menu-tool, it creates the symlink in wrong directory.

The desktop files of 3rd part kcontrol plugin are usually installed under
/usr/share/applnk/Settings/ as default. By running desktop-menu-tool the
symlinks should be created in /var/lib/menu/kde/Applications/Preferences/
instead /var/lib/menu/kde/Applications/Extras/Other/

e.g. the desktop file of mosfet-liquid is installed under
/usr/share/applnk/Settings/LookNFeel/, if we convert it, it should be in

Comment 2 Miloslav Trmac 2002-10-17 07:37:08 EDT
Isn't the original reporter talking about bug #74701?
Comment 3 Havoc Pennington 2002-12-19 18:21:38 EST
#74701 is something about locales? doesn't look related.

The current menu setup is that pretty much all 3rd-party stuff ends up in 
Extras, though we're looking at changing that, it's not yet clear how.

I'm not sure if that should impact whether we find the modules though.
Comment 4 Miloslav Trmac 2002-12-20 05:33:13 EST
That is bug # 74071, sorry (IOW, should be fixed by recent KDE errata)
Comment 5 Havoc Pennington 2002-12-20 09:56:41 EST
It sounds to me like #74071 does indeed fix this. If I'm wrong, 
someone reopen the bug.

*** This bug has been marked as a duplicate of 74071 ***
Comment 6 Red Hat Bugzilla 2006-02-21 13:49:58 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.