Bug 76111 - glibc-2.2.4-30 cause crash of mysqld and lotus domino
glibc-2.2.4-30 cause crash of mysqld and lotus domino
Status: CLOSED DUPLICATE of bug 75128
Product: Red Hat Linux
Classification: Retired
Component: mysql (Show other bugs)
7.2
i386 Linux
high Severity low
: ---
: ---
Assigned To: Patrick Macdonald
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-16 18:00 EDT by Jan Polak
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-18 07:55:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Polak 2002-10-16 18:00:52 EDT
Description of Problem:

After upgrade to glibc-2.2.4-30 and restart of mysql daemon
the mysqld seg. fault on any remote connection to tcp port 3306
Local connections are OK.

mysqld with option --skip-name-resolve works fine with local
connections and remote tcp connections too.

lotus domino server crash when smtp task opens
connection to remote server.

after downgrade to  glibc 2.2.4-29 mysqld and domino 
works fine



Version-Release number of selected component (if applicable):

RH 7.1, RH 7.2

glibc-2.2.4-30
mysql-server-3.23.41-1
mysql-server-3.23.36-1cz1

lotus domino 5.0.9, 5.0.10



How Reproducible:

 always



Steps to Reproduce:
1. upgrade to glibc-2.2.4-30
2. restart mysql (or domino)
3. connect to mysql from remote machine

it always return: 
# mysql -h mysqlserver database
ERROR 2013: Lost connection to MySQL server during query

and mysql server seg.fault:


sigreturn()                             = ? (mask now [HUP QUIT PIPE TERM TSTP])
fstat64(1, {st_mode=S_IFREG|0644, st_size=28010, ...}) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x40017000
write(1, "/usr/libexec/mysqld: ready for c"..., 43/usr/libexec/mysqld: ready for
connections
) = 43
sched_getscheduler(0xea8)               = 0
sched_getparam(0xea8, 0xbffff434)       = 0
fcntl64(0x3, 0x3, 0, 0x3)               = 2
fcntl64(0x4, 0x3, 0, 0x3)               = 2
select(5, [3 4], NULL, NULL, NULL)      = 1 (in [3])
fcntl64(0x3, 0x4, 0x802, 0x4)           = 0
accept(3, {sin_family=AF_INET, sin_port=htons(61016),
sin_addr=inet_addr("10.10.17.61")}}, [16]) = 7
fcntl64(0x3, 0x4, 0x2, 0x4)             = 0
getsockname(7, {sin_family=AF_INET, sin_port=htons(3306),
sin_addr=inet_addr("10.10.16.228")}}, [16]) = 0
fcntl64(0x7, 0x3, 0x7, 0x3)             = 2
brk(0x827e000)                          = 0x827e000
fcntl64(0x7, 0x4, 0x802, 0x4)           = 0
time(NULL)                              = 1034784398
rt_sigprocmask(SIG_SETMASK, NULL, [HUP QUIT PIPE TERM TSTP 32], 8) = 0
write(6, "\240%\3@\0\0\0\0@8$\0100n\v\10\360m&\10\5P\10\200\0\0\0"..., 148) =
148
rt_sigprocmask(SIG_SETMASK, NULL, [HUP QUIT PIPE TERM TSTP 32], 8) = 0
rt_sigsuspend([HUP QUIT PIPE TERM TSTP] <unfinished ...>
--- SIGRT_0 (Real-time signal 0) ---
<... rt_sigsuspend resumed> )           = -1 EINTR (Interrupted system call)
sigreturn()                             = ? (mask now [HUP QUIT PIPE TERM TSTP])
select(5, [3 4], NULL, NULL, NULL)      = ? ERESTARTNOHAND (To be restarted)
--- SIGSEGV (Segmentation fault) ---
+++ killed by SIGSEGV +++




Actual Results:

mysqld or domino server crash



Expected Results:


Additional Information:

  lotus domino needs compat-glibc on rh 7.x systems
Comment 1 Jan Polak 2002-10-17 03:48:24 EDT
mysql and lotus domino works fine after upgrade to glibc 2.2.4-31
from  ftp://people.redhat.com/jakub/glibc/errata/7.2/i386/
Comment 2 Alain D D Williams 2002-10-18 07:15:11 EDT
If you have a limited number of hosts that connect, you can add the clients to
/etc/hosts - this works around the problem.

This also affects RedHat 7.3
Comment 3 Alain D D Williams 2002-10-18 07:55:17 EDT
I was getting intermittent problems from samba users. Putting their IP addresses
into /etc/hosts cured the problem. So this problem also seems to affect samba.
This is serious.
Comment 4 Jakub Jelinek 2002-10-18 16:20:31 EDT

*** This bug has been marked as a duplicate of 75128 ***

Note You need to log in before you can comment on or make changes to this bug.