Bug 761118 - grub2.cfg not updating correctly for Windows 7 default
grub2.cfg not updating correctly for Windows 7 default
Status: CLOSED DUPLICATE of bug 742720
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-07 12:50 EST by Jeff Guerdat
Modified: 2011-12-08 14:25 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-08 14:25:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Guerdat 2011-12-07 12:50:46 EST
Description of problem:

A kernel update still strips out spaces in the set default= line.  Should be set default="Windows 7 (loader) (on /dev/sda2)" but ends up with set default="Windows7(loader)(on /dev/sda2)".

Version-Release number of selected component (if applicable):
grub2-1.99-12

How reproducible:
Always on kernel update

Steps to Reproduce:
1. Install new kernel
2. check grub2.cfg
3.
  
Actual results:
First 3 spaces are stripped out

Expected results:
spaces should be maintained

Additional info:
Ever since a fresh load of F16 with a Windows 7 installation a kernel update will not correctly update grub2.cfg to use the W7 install as default.  I've slowly learned to manually set the default via commandline and to edit /etc/default/grub to used the saved configuration but a kernel update still strips out spaces in the default= line.  Not sure why there's no tool to easily set the default correctly - needed to use Ubuntu support forums to discern what was needed.  Again, it should be:
set default="Windows 7 (loader) (on /dev/sda2)" 
but ends up with:
set default="Windows7(loader)(on /dev/sda2)".

On a side (related?) note, anaconda for the fresh install never even considered asking which OS to set as default.
Comment 1 Mads Kiilerich 2011-12-08 14:25:12 EST

*** This bug has been marked as a duplicate of bug 742720 ***

Note You need to log in before you can comment on or make changes to this bug.