Bug 76117 - openoffice setup dies for any user
Summary: openoffice setup dies for any user
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openoffice.org   
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-17 00:03 UTC by Hans Ecke
Modified: 2007-04-18 16:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-27 15:54:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hans Ecke 2002-10-17 00:03:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux; , en_US, en)

Description of problem:
After installing a fresh 8.0 system (including openoffice), openoffice does not start for any user. Terminal shows that the setup program segfaults. Umask/permission problems?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install a fresh 8.0 including openoffice
2.try starting ooffice from the command line
3.get the error message
	

Actual Results:  Got an error message complaining that setup segfaulted.
A quick "strace" showed that setup dies after reading in many fonts, wherever that might be.

Expected Results:  setup should come up.

Additional info:

I think this is an umask or permission problem. I usually run with 0026 (root) or 0066 (user). 

The problem can be fixed with

   chmod ugoa+rX /usr/lib/openoffice
   chmod ugoa+rX /etc/openoffice

Now openoffice runs perfectly.

Comment 1 Hans Ecke 2002-10-18 17:44:01 UTC
Sorry, I made a mistakes in the description:   
   
Instead of   
       chmod ugoa+rX /usr/lib/openoffice  
       chmod ugoa+rX /etc/openoffice  
it should read  
       chmod -R ugoa+rX /usr/lib/openoffice  
       chmod -R ugoa+rX /etc/openoffice  
  
And I made the comment about the umask because the default umask for RedHat is  
much more permissive than 066/026.  
  


Comment 2 Dan Williams 2004-02-27 15:54:17 UTC
fixed


Note You need to log in before you can comment on or make changes to this bug.