Bug 76119 - HTTP Config Bug
Summary: HTTP Config Bug
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-httpd   
(Show other bugs)
Version: 8.0
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: jkomendar
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-17 02:12 UTC by Need Real Name
Modified: 2015-03-05 01:11 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-29 13:28:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-10-17 02:12:12 UTC
Description of Problem:
The graphical HTTP Configurator does not include the 'DirectoryIndex' command 
nor any of the files listed.

Version-Release number of selected component (if applicable):
RH 8.0

How Reproducible:
Always 

Steps to Reproduce:
1. Load the HTTP Configuration
2. Edit the files to look for with the directory
3. save httpd.conf file
4. Files are NOT referenced. 

Actual Results:
No reference to files

Expected Results:
The insertion of DirectoryIndex with files names

Additional Information:
Causes an error when referencing site that says cannot access w/ http since 
talking to a secured port 443.

Comment 1 Mihai Ibanescu 2002-10-21 14:59:44 UTC
This does not seem to be related to RHN at all. Trying to guess the right
component this bug should be filed against.

rob, please feel free to correct my poor choice. Bugs are unlikely to be seen
unless they are filed against the right component.

Comment 2 Bojan Smojver 2003-02-17 01:17:56 UTC
Just confirming this bug. Basically, you'll get a 403 because DirectoryIndex is
empty and the global option includes -Indexes. The workaround is to reshuffle
the index.* files, but that only works occasionally.

Another interesting bug is that when multiple listening ports are specified, the
tool attempts to put them on the same line, like this:

Listen 80 443

This, of course, won't work in Apache, so httpd won't even start.

All this makes the tool unusable in real life.

Bojan

Comment 3 Phil Knirsch 2003-10-29 13:28:26 UTC
Is fixed in latest rawhide build (redhat-config-httpd-1.1.0-5 and later).

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.