Bug 761200 - error in image build results in web ui internal server error
error in image build results in web ui internal server error
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Provaznik
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-07 15:59 EST by Dave Johnson
Modified: 2012-05-15 17:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 17:22:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ss (32.63 KB, image/png)
2011-12-07 15:59 EST, Dave Johnson
no flags Details

  None (edit)
Description Dave Johnson 2011-12-07 15:59:08 EST
Description of problem:
===============================
Created a new image using the conductor web ui uploading a rhel61 template without the <rootpw> element which is required.  Building this template resulted in a oz exception within imagefactory which caused a internal server error to display in the web ui when encountered during the build.


Version-Release number of selected component (if applicable):
================================================================
aeolus-all-0.7.0-4.el6.noarch
aeolus-conductor-0.7.0-4.el6.noarch
aeolus-conductor-daemons-0.7.0-4.el6.noarch
aeolus-conductor-doc-0.7.0-4.el6.noarch
aeolus-configure-2.4.0-3.el6.noarch
imagefactory-1.0.0rc1-1.el6.noarch
imagefactory-jeosconf-ec2-fedora-1.0.0rc1-1.el6.noarch
imagefactory-jeosconf-ec2-rhel-1.0.0rc1-1.el6.noarch
iwhd-1.1-7.el6.x86_64
rubygem-aeolus-cli-0.2.0-3.el6.noarch
rubygem-aeolus-image-0.2.0-1.el6.noarch
rubygem-imagefactory-console-0.4.0-1.el6.noarch


Additional info:
==================================
 Processing by ImagesController#rebuild_all as HTML
  Parameters: {"authenticity_token"=>"Amq2/qWISWC0/SsECe+2n+JGarfd9REW3wCMLCrNEK8=", "id"=>"3e54c2b4-2115-11e1-8509-5cf3fc1c84a8"}
  ^[[1m^[[35mUser Load (0.7ms)^[[0m  SELECT "users".* FROM "users" WHERE "users"."id" = 1 LIMIT 1
  ^[[1m^[[36mBasePermissionObject Load (0.5ms)^[[0m  ^[[1mSELECT "base_permission_objects".* FROM "base_permission_objects" WHERE "base_permission_objects"."name" = 'general_permission_scope' LIMIT 1^[[0m
  ^[[1m^[[35mCACHE (0.0ms)^[[0m  SELECT "base_permission_objects".* FROM "base_permission_objects" WHERE "base_permission_objects"."name" = 'general_permission_scope' LIMIT 1
  ^[[1m^[[36mPermission Load (1.0ms)^[[0m  ^[[1mSELECT * FROM (SELECT DISTINCT ON ("permissions".id) "permissions".id, permissions.id AS alias_0 FROM "permissions" LEFT OUTER JOIN "roles" ON "roles"."id" = "permissions"."role_id" LEFT OUTER JOIN "privileges" ON "privileges"."role_id" = "roles"."id" WHERE ("permissions".permission_object_id = 1 AND "permissions".permission_object_type = 'BasePermissionObject') AND (permissions.user_id=1 and
 privileges.target_type='Provider' and
 privileges.action='view')) AS id_list ORDER BY id_list.alias_0 LIMIT 1^[[0m
  ^[[1m^[[35mPermission Load (1.0ms)^[[0m  SELECT "permissions"."id" AS t0_r0, "permissions"."role_id" AS t0_r1, "permissions"."user_id" AS t0_r2, "permissions"."permission_object_id" AS t0_r3, "permissions"."permission_object_type" AS t0_r4, "permissions"."lock_version" AS t0_r5, "permissions"."created_at" AS t0_r6, "permissions"."updated_at" AS t0_r7, "roles"."id" AS t1_r0, "roles"."name" AS t1_r1, "roles"."scope" AS t1_r2, "roles"."lock_version" AS t1_r3, "roles"."created_at" AS t1_r4, "roles"."updated_at" AS t1_r5, "roles"."assign_to_owner" AS t1_r6, "privileges"."id" AS t2_r0, "privileges"."role_id" AS t2_r1, "privileges"."target_type" AS t2_r2, "privileges"."action" AS t2_r3, "privileges"."lock_version" AS t2_r4, "privileges"."created_at" AS t2_r5, "privileges"."updated_at" AS t2_r6 FROM "permissions" LEFT OUTER JOIN "roles" ON "roles"."id" = "permissions"."role_id" LEFT OUTER JOIN "privileges" ON "privileges"."role_id" = "roles"."id" WHERE "permissions"."id" IN (6) AND ("permissions".permission_object_id = 1 AND "permissions".permission_object_type = 'BasePermissionObject') AND (permissions.user_id=1 and
 privileges.target_type='Provider' and
 privileges.action='view') ORDER BY permissions.id ASC
  ^[[1m^[[36mProvider Load (0.4ms)^[[0m  ^[[1mSELECT "providers".* FROM "providers"^[[0m
  ^[[1m^[[35mProviderType Load (0.4ms)^[[0m  SELECT "provider_types".* FROM "provider_types" WHERE "provider_types"."id" = 2 LIMIT 1
  ^[[1m^[[36mCACHE (0.0ms)^[[0m  ^[[1mSELECT "provider_types".* FROM "provider_types" WHERE "provider_types"."id" = 2 LIMIT 1^[[0m
  ^[[1m^[[35mCACHE (0.0ms)^[[0m  SELECT "provider_types".* FROM "provider_types" WHERE "provider_types"."id" = 2 LIMIT 1
  ^[[1m^[[36mCACHE (0.0ms)^[[0m  ^[[1mSELECT "provider_types".* FROM "provider_types" WHERE "provider_types"."id" = 2 LIMIT 1^[[0m
  ^[[1m^[[35mCACHE (0.0ms)^[[0m  SELECT "provider_types".* FROM "provider_types" WHERE "provider_types"."id" = 2 LIMIT 1
  ^[[1m^[[36mCACHE (0.0ms)^[[0m  ^[[1mSELECT "provider_types".* FROM "provider_types" WHERE "provider_types"."id" = 2 LIMIT 1^[[0m
  ^[[1m^[[35mProviderType Load (0.4ms)^[[0m  SELECT "provider_types".* FROM "provider_types" WHERE "provider_types"."id" = 5 LIMIT 1
Failed.  Response code = 500.  Response message = Internal Server Error.
/usr/lib/ruby/gems/1.8/gems/activeresource-3.0.10/lib/active_resource/connection.rb:147:in `handle_response'
 /usr/lib/ruby/gems/1.8/gems/aeolus-image-0.2.0/lib/aeolus_image/active_resource_oauth_client.rb:52:in `request'
 /usr/lib/ruby/gems/1.8/gems/activeresource-3.0.10/lib/active_resource/connection.rb:91:in `put'
 /usr/lib/ruby/gems/1.8/gems/activeresource-3.0.10/lib/active_resource/connection.rb:217:in `with_auth'
 /usr/lib/ruby/gems/1.8/gems/activeresource-3.0.10/lib/active_resource/connection.rb:91:in `put'
 /usr/lib/ruby/gems/1.8/gems/activeresource-3.0.10/lib/active_resource/base.rb:1307:in `update_without_notifications'
 /usr/lib/ruby/gems/1.8/gems/activeresource-3.0.10/lib/active_resource/observing.rb:11:in `update'
 /usr/lib/ruby/gems/1.8/gems/activeresource-3.0.10/lib/active_resource/base.rb:1117:in `save_without_validation'
 /usr/lib/ruby/gems/1.8/gems/activeresource-3.0.10/lib/active_resource/validations.rb:87:in `save_without_notifications'
 /usr/lib/ruby/gems/1.8/gems/activeresource-3.0.10/lib/active_resource/observing.rb:11:in `save'
 /usr/lib/ruby/gems/1.8/gems/activeresource-3.0.10/lib/active_resource/base.rb:1134:in `save!'
 /usr/share/aeolus-conductor/app/controllers/images_controller.rb:53:in `rebuild_all'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_controller/metal/implicit_render.rb:4:in `send_action'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_controller/metal/implicit_render.rb:4:in `send_action'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/abstract_controller/base.rb:150:in `process_action'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_controller/metal/rendering.rb:11:in `process_action'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/abstract_controller/callbacks.rb:18:in `process_action'
 /usr/lib/ruby/gems/1.8/gems/activesupport-3.0.10/lib/active_support/callbacks.rb:446:in `_run__252996427__process_action__780225233__callbacks'
 /usr/lib/ruby/gems/1.8/gems/activesupport-3.0.10/lib/active_support/callbacks.rb:410:in `send'
 /usr/lib/ruby/gems/1.8/gems/activesupport-3.0.10/lib/active_support/callbacks.rb:410:in `_run_process_action_callbacks'
 /usr/lib/ruby/gems/1.8/gems/activesupport-3.0.10/lib/active_support/callbacks.rb:94:in `send'
 /usr/lib/ruby/gems/1.8/gems/activesupport-3.0.10/lib/active_support/callbacks.rb:94:in `run_callbacks'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/abstract_controller/callbacks.rb:17:in `process_action'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_controller/metal/rescue.rb:17:in `process_action'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_controller/metal/instrumentation.rb:30:in `process_action'
 /usr/lib/ruby/gems/1.8/gems/activesupport-3.0.10/lib/active_support/notifications.rb:52:in `instrument'
 /usr/lib/ruby/gems/1.8/gems/activesupport-3.0.10/lib/active_support/notifications/instrumenter.rb:21:in `instrument'
 /usr/lib/ruby/gems/1.8/gems/activesupport-3.0.10/lib/active_support/notifications.rb:52:in `instrument'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_controller/metal/instrumentation.rb:29:in `process_action'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/abstract_controller/base.rb:119:in `process'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/abstract_controller/rendering.rb:41:in `process'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_controller/metal.rb:138:in `dispatch'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_controller/metal/rack_delegation.rb:14:in `dispatch'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_controller/metal.rb:178:in `action'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_dispatch/routing/route_set.rb:62:in `call'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_dispatch/routing/route_set.rb:62:in `dispatch'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_dispatch/routing/route_set.rb:27:in `call'
 /usr/lib/ruby/gems/1.8/gems/rack-mount-0.7.1/lib/rack/mount/route_set.rb:150:in `call'
 /usr/lib/ruby/gems/1.8/gems/rack-mount-0.7.1/lib/rack/mount/code_generation.rb:93:in `recognize'
 /usr/lib/ruby/gems/1.8/gems/rack-mount-0.7.1/lib/rack/mount/code_generation.rb:68:in `optimized_each'
 /usr/lib/ruby/gems/1.8/gems/rack-mount-0.7.1/lib/rack/mount/code_generation.rb:92:in `recognize'
Comment 1 Dave Johnson 2011-12-07 15:59:59 EST
Created attachment 542188 [details]
ss
Comment 2 Jan Provaznik 2011-12-12 10:37:49 EST
it turned out that rootpw is now reuired parameter in imagefactory for all targets, so I made this param required in relaxng schema -> now it's not possible to create template w/o roopw param.

commit ea32f345a3bfdee13d0f0aace0cec13f16ea093
Comment 3 Shveta 2011-12-30 09:45:58 EST
Creating an image with a template without rootpw gives the following error message on UI 

    XML is not valid:
    Expecting an element rootpw, got nothing
    Invalid sequence in interleave
    Element os failed to validate content


Verified in 
rpm -qa|grep aeolus
aeolus-conductor-doc-0.8.0-0.20111222233342gitd98cb57.el6.noarch
rubygem-aeolus-image-0.3.0-0.20111222173411gitc13b654.el6.noarch
rubygem-aeolus-cli-0.3.0-0.20111222173356git3cd6277.el6.noarch
aeolus-conductor-0.8.0-0.20111222233342gitd98cb57.el6.noarch
aeolus-configure-2.5.0-0.20111222173430git17b704a.el6.noarch
aeolus-all-0.8.0-0.20111222233342gitd98cb57.el6.noarch
aeolus-conductor-daemons-0.8.0-0.20111222233342gitd98cb57.el6.noarch
Comment 4 wes hayutin 2012-01-03 09:30:21 EST
These bugs are verified, removing from ce-sprint
Comment 6 errata-xmlrpc 2012-05-15 17:22:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0583.html

Note You need to log in before you can comment on or make changes to this bug.