Bug 76141 - can't build modules from 2.4.18-17.7.x sources
Summary: can't build modules from 2.4.18-17.7.x sources
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-17 14:08 UTC by Dave Strauss
Modified: 2007-04-18 16:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-17 16:18:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
make modules log (112.38 KB, text/plain)
2002-10-17 14:09 UTC, Dave Strauss
no flags Details

Description Dave Strauss 2002-10-17 14:08:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
This morning I installed the kernel-2.4.18-17.7.x and
kernel-source-2.4.18-17.7.x rpm's, then I tried to rebuild the
kernel and the modules like so (as root):
      cd /usr/src/linux2-4
      cp configs/kernel-2.4.18-i686.config .config
      make oldconfig
      make dep
      make bzImage
      make modules

All steps including building the kernel seem to work, but when I
build the modules I get compilation errors (see attached build
log).
 

Version-Release number of selected component (if applicable):2.4.18-17.7x


How reproducible:
Always
Steps to Reproduce:
1.install 2.4.18-17.7x kernel and kernel-source rpm's
2.try to rebuild kernel and modules
3.
	

Actual Results:  compilation errors:



Expected Results:  should have build the modules

Additional info:

Comment 1 Dave Strauss 2002-10-17 14:09:35 UTC
Created attachment 80784 [details]
make modules log

Comment 2 Arjan van de Ven 2002-10-17 14:27:05 UTC
looks like you forgot make mrproper

Comment 3 Dave Strauss 2002-10-17 16:18:12 UTC
OK, I'll try that when I get a chance (although at this point it
may take a while).  [whatever happened to just good old "make clean"?]
In the meantime this bug should probably be closed unless someone else
has the same problem.


Comment 4 Dave Strauss 2002-10-17 17:32:54 UTC
Running "make mrproper" first fixed the problem, so I'm closing it as
"not a bug".  Maybe I should RTFM next time?


Comment 5 Adam Pribyl 2002-11-03 13:13:39 UTC
That mrproper was not done before somebody packed kernel-source rpm.


Note You need to log in before you can comment on or make changes to this bug.