Bug 76157 - Depmod segfault after upgrade to new kernel.
Summary: Depmod segfault after upgrade to new kernel.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 8.0
Hardware: i586 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-17 17:39 UTC by Need Real Name
Modified: 2007-04-18 16:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-17 17:40:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-10-17 17:39:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
When booting the modules do not load. Found that no dep files was created in the
module library. Running depmod on comandline make
it segfault.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Running an upgraded version from RH7.3 to RH8.0 on an AMD550
and a FIC VA-503+. No problems runing on standard kernel.

2.Upgrade from 2.4.18-14 to kernel 2.4.18-17.8.0 by up2date.

3.Reboot to new kernel.
	

Actual Results:  When booting the modules do not load.

Expected Results:  Run as normal.

Additional info:

Running depmod on comandline make it segfault.
error: 
local symbol free_pages_R9941ccb8 with index 91 exceeds local_symtab_size 76

local symbol with index 92 exceeds local_symtab_size 76

Comment 1 Need Real Name 2002-10-18 15:24:58 UTC
Found the problem.

Corrupted files in the modules library.
MD5 sum do not match after install.

The problem is the hardware.

Probobly related to the udma on the disk.


Note You need to log in before you can comment on or make changes to this bug.