Bug 761591 - xen-netfront: wait with gARP notification until backend moves to Connected status [TestOnly]
xen-netfront: wait with gARP notification until backend moves to Connected st...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kernel (Show other bugs)
7.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Virtualization Bugs
xen
: EC2, TestOnly
Depends On: 866735
Blocks: 741684
  Show dependency treegraph
 
Reported: 2011-12-08 11:48 EST by Laszlo Ersek
Modified: 2014-06-18 01:36 EDT (History)
9 users (show)

See Also:
Fixed In Version: v3.3-rc1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 713585
Environment:
Last Closed: 2014-06-13 07:35:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 9 Lingfei Kong 2014-02-14 02:05:10 EST
I did migration test on RHEL5.10 with RHEL7.0, it got 7-15 packet lost during the migration.
Also I have try to set the net.ipv4.conf.{all,default,IFACE}.arp_notify sysctl to 1 in the guest and did migration test again but the network still lost about 7-15 packet. 
Is it acceptable with lost 7-15 packet? 

Host: kernel-xen-2.6.18-380.el5
Guest: kernel-3.10.0-86.el7

Here are the details:
1. Start nfs in System A and mount the nfs to System B.
  #mount $SystemA_ip:/var/lib/xen/images /var/lib/xen/images

2. Edit "/etc/xen/xend-config.sxp" on two machines as following:
   (xend-relocation-server yes)
   (xend-relocation-port 8002)
   (xend-relocation-address '')
   (xend-relocation-hosts-allow '')
# service xend restart

3. Do migration operations
System A to System B:
--- 10.66.85.222 ping statistics ---
23 packets transmitted, 16 received, 30% packet loss, time 24355ms
rtt min/avg/max/mdev = 0.552/2.155/18.863/4.389 ms

System B  to System A:
--- 10.66.85.222 ping statistics ---
25 packets transmitted, 15 received, 40% packet loss, time 27388ms
rtt min/avg/max/mdev = 0.000/2.422/10.114/3.199 ms

System A to System B:
--- 10.66.85.222 ping statistics ---
20 packets transmitted, 14 received, 30% packet loss, time 22685ms

System B to  System A:
--- 10.66.85.222 ping statistics ---
26 packets transmitted, 16 received, 38% packet loss, time 27730ms
rtt min/avg/max/mdev = 0.000/4.141/49.098/11.691 ms
Comment 10 Andrew Jones 2014-02-14 03:06:06 EST
(In reply to Lingfei Kong from comment #9)
> I did migration test on RHEL5.10 with RHEL7.0, it got 7-15 packet lost
> during the migration.
> Also I have try to set the net.ipv4.conf.{all,default,IFACE}.arp_notify
> sysctl to 1 in the guest and did migration test again but the network still
> lost about 7-15 packet. 
> Is it acceptable with lost 7-15 packet? 

Yeah, that's fine. Thanks.
Comment 11 Lingfei Kong 2014-02-14 03:17:42 EST
Because 7-15 packet lost is acceptable, so change status to VERIFIED.
Comment 12 Ludek Smid 2014-06-13 07:35:49 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.