Bug 76163 - getOutputFrom(): broken pipe while finding provides
getOutputFrom(): broken pipe while finding provides
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-17 14:18 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-17 14:19:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-17 14:18:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux)

Description of problem:
building an RPM of my app failed on RH 8.0 with the above error. In 7.3 everything was ok.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. download kwifimanager-1.0.0.tar.gz from http://sourceforge.net/projects/kwifimanager
2. grab .spec and .xpm file from CVS
3. build as usual with rpmbuild -ba kwifimanager.spec
	

Actual Results:  the whole build went okay, except for finding-provides, which failed with getOutputFrom(): broken pipe. As a result, RPMs were not built.

Expected Results:  Expected a painless build of kwifimanager.

Additional info:
Comment 1 Jeff Johnson 2002-10-25 14:44:52 EDT
Hmmm, this package does not have a build root.
Adding a BuildRoot: to the package is strongly
suggested.

I can't reproduce an error with find-provides,
only with check-files that takes a (undefined)
%{buildroot} argument, perhaps that's what you
are seeing? If it is in find-provides, then

	cat files.txt | /usr/lib/rpm/find-provides

is all that rpm is doing.

Adding
	%define __check_files %{nil}
will disable the functionality.
Comment 2 wibble123 2003-01-04 16:48:50 EST
Hi,

I'm also getting a simular error as above. I've managed to narrow the posible
cause to the length of the files list when building. So for whenI have less than
20 files in the list it moslty works but as more and more files are added it
fails more and more often. The order doen't seem to matter but I have a supicion
that the real memory/swap boundary might have an effect. i.e. as swap is used. (
I have a swap file rather than partition.)

I'm buiding in a root env using an image of 8.0 which otherwise works fine. Here
is an example -:

snip-----
cat ./foobar/tmp/files-bak | sort | head -n 20 > ./foobar/tmp/files
su -c "/usr/sbin/chroot ./foobar /rpm.sh"
......
Checking for unpackaged file(s): /usr/local/lib/rpm/check-files %{buildroot}
warning: Could not canonicalize hostname: sue
Wrote: /usr/local/src/redhat/SRPMS/perl-5.8.0-1.src.rpm
Wrote: /usr/local/src/redhat/RPMS/i386/perl-5.8.0-1.i386.rpm

...

cat ./foobar/tmp/files-bak | sort | head -n 41 > ./foobar/tmp/files
su -c "/usr/sbin/chroot ./foobar /rpm.sh"
...

Checking for unpackaged file(s): /usr/local/lib/rpm/check-files %{buildroot}
getOutputFrom(): Broken pipe


snip-----
Comment 3 Elmo 2003-02-19 13:15:03 EST
I get the same error from check-files: 

Checking for unpackaged file(s): /usr/lib/rpm/check-files %{buildroot}
getOutputFrom(): Broken pipe


-Elmo

Note You need to log in before you can comment on or make changes to this bug.