Bug 76177 - grub-install not being run after update
grub-install not being run after update
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-17 16:48 EDT by David Juran
Modified: 2008-02-14 07:17 EST (History)
1 user (show)

See Also:
Fixed In Version: anaconda-11.3.0.50-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-14 07:17:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
grub.conf (772 bytes, text/plain)
2002-11-02 11:07 EST, David Juran
no flags Details

  None (edit)
Description David Juran 2002-10-17 16:48:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
When I tried to boot after upgrading to RH 8.0 from 7.3 all I got was the text
GRUB. Booting from the rescue cd and manually running grub-install /dev/hda 
remedied the problem. My root partition resides on hdd2 and boot on hdd1.
Could it be so that anaconda noticed that I already was running grub and decided
it didn't need to install although it really did?

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try




Additional info:
Comment 1 Jeremy Katz 2002-10-17 17:08:50 EDT
What option did you select on the screen where you were asked about what to do
with the boot loader?
Comment 2 David Juran 2002-10-18 07:10:34 EDT
update existing configuration
Comment 3 StK 2002-10-18 09:52:23 EDT
Had the same on my pc...
using lilo did work!!!
Comment 4 Jeremy Katz 2002-10-24 17:44:48 EDT
Could you attach your /boot/grub/grub.conf file?
Comment 5 David Juran 2002-11-02 11:07:56 EST
Created attachment 83185 [details]
grub.conf
Comment 6 David Juran 2002-11-02 11:09:21 EST
Sorry for the long delay. Do note that I've upgraded to the kernel from the
errata since I've installed RH8.0
Comment 7 Jeremy Katz 2002-11-05 13:42:04 EST
Hrmm... everything looks like it should have worked fine.  I'll try some to
reproduce here while doing some other upgrade tests.
Comment 8 Jeremy Katz 2003-01-03 00:01:01 EST
I've made some changes in this area that should prevent this happening in the
future, although I haven't been able to reproduce it myself
Comment 9 Brent Fox 2003-05-25 10:50:48 EDT
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.
Comment 10 David Juran 2003-11-10 04:51:46 EST
Got the same problem when upgrading from RHL9 to Fedora Core 1
Comment 11 Daniel Lemye 2003-12-14 13:08:35 EST
Since my lastest update (kernel) of RH9, GRUB doesn't start anymore
(screen shows "GRUB _" and PC stops). 
GRUB is on hdc2 (/boot). linux.bin in on hda1, launched by W2K boot
manager.
I have reinstalled GRUB many times (grub-install /dev/hdc2) with no
result.
Everything worked OK before update.
How could I switch to LILO ?
Dan
Comment 12 Pavel Roskin 2004-05-22 01:24:50 EDT
I hit this bug too.  I installed Fedora Core 2.  In the first pass, I
chose not to install GRUB because I had one in MBR, with the files on
my Debian partition.  FC2 would not allow me to log in as root or as
user (maybe an unrelated bug), so I decided to upgrade to Fedora Core
2 from the same CD.  I chose to install GRUB to the FC2 partition,
which was /dev/hda3.  After reboot I found that there was no valid
bootsector in the first block of /dev/hda3 (i.e. GRUB wasn't
installed).  Also, /boot/grub/grub.conf was missing on /dev/hda3.
Comment 13 David Juran 2004-11-25 13:07:27 EST
Actually seems to work now when I upgraded to FC3 (-:
Comment 14 David Juran 2006-12-11 07:39:35 EST
This problem re-appeared when I upgraded my system from FC5 to FC6. After
upgrading  the machine wouldn't boot from the HD. The solution was (as usual) to
boot it from the rescue DVD and run grub-install
Comment 15 petrosyan 2008-02-14 00:38:38 EST
Fedora Core 6 is not maintained anymore.

Can you reproduce this bug in the latest Fedora 8 release?
Comment 16 David Juran 2008-02-14 07:17:05 EST
No, the update to F8 went smooth (-: Closing this issue.

Note You need to log in before you can comment on or make changes to this bug.