Bug 76199 - Wireless Cards Don't Initialize Right If iwconfig is not in /sbin
Wireless Cards Don't Initialize Right If iwconfig is not in /sbin
Status: CLOSED DUPLICATE of bug 74873
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Brock Organ
:
Depends On:
Blocks: 81720
  Show dependency treegraph
 
Reported: 2002-10-17 23:08 EDT by Rob Thorne
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Thorne 2002-10-17 23:08:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
The file ifcfg-wireless never runs if iwconfig is not in /sbin (say, because it
was built manually), or if wireless-tools is not installed. This causes at least
the following symptoms:

1) If a KEY is required for WEP encryption, the "neat" configuration tool will
correctly place the KEY parameter into the ifcfg-ethX file, but it will never be
set for the wireless interface.

2) NAME won't be set correctly either.


The problem is in the is_wireless_device function found in
/etc/sysconfig/network-scripts/network-functions, which exits silently with an
error if /sbin/iwconfig does not exist and is not executable.
This fails silently, and is very difficult to debug for both the customer and
for RedHat tech support (which was telling me to rebuild by kernel, BTW...).

I fixed this for my own system (which has iwconfig at /usr/local/bin/iwconfig)
by making a symbolic link to /usr/local/bin/iwconfig.

I'd suggest one of the following types of fixes for this:

1) either make the is_wireless_device a bit more intelligent about iwconfig's
location, or

2) Have "neat" look for wireless-tools, and either (a) refuse to install with
it, or (2) have the UI for Wireless deactivated if iwconfig cannot be found.

It's a pity not to do this, since RedHat's interface is very easy to use if
wireless-tools is installed as expected.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
0. Make sure the wireless-tools is not installed (as seems to be the default in
RHL 8.0), and install the Wireless Tool package by hand at its default position
(/usr/local). [this is not uncommon for upgrading Redhat customers!]
1. Configure a wireless card in "neat" to use a WEP key (I'm assuming you have
access to a Wireless access point that is configured for WEP).
2. Confirm that the KEY parameter is set for the ethX interface in question (in
/etc/sysconfig/network-scripts/ifcfg-ethX).
3. Let's assume that the wireless interface is on eth1; if so, try this, as root:
   ifconfig eth1 up

4. Now restart your system with the wireless card inserted into a PCMCIA slot. 
If the card is supported (I used an Orinoco Silver, which is supported in
default RHL 8.0), PCMCIA and the card will initialize with 2 identical beeps.

5. Once the system is all the way up, open a terminal window and try this as root:

iwconfig eth1

You will see that iwconfig recognizes the card as wireless, but that only some
of the fields are set; notably, you will see "Encryption off", rather than the
value of the WEP key.  This is the bug; it prevents the wireless card from
communicating with the access point.

6. Now symlink iwconfig to /sbin/iwconfig, and restart again.
7. Now do iwconfig as root again.  Now the encryption key *is* set, and you have
a good connection with the access point.

Additional info:
Comment 1 Bill Nottingham 2002-11-12 00:44:56 EST
We could have redhat-config-network deactivate wireless if the tools are not
installed, I suppose. I don't necessarily see the point of changing the path
search, as it looks for iwconfig where we install it at.
Comment 2 Harald Hoyer 2003-01-13 09:44:29 EST

*** This bug has been marked as a duplicate of 74873 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:49:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.