Bug 76218 - magicdev interferes with xcdroast
magicdev interferes with xcdroast
Status: CLOSED DUPLICATE of bug 34433
Product: Red Hat Linux
Classification: Retired
Component: magicdev (Show other bugs)
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Owen Taylor
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-10-18 07:30 EDT by Rick Richardson
Modified: 2007-03-26 23:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-10-24 20:03:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Rick Richardson 2002-10-18 07:30:49 EDT
Description of Problem:

magicdev interferes with xcdroast, causing xcdroast to create coasters. 

How Reproducible: always

Steps to Reproduce:
1.  Stock RH 8.0 installation
2.  Try to burn a CDR using xcdroast

Actual Results: you get errors from xcdroast right away and the CDR is unusable.

Expected Results:  no errors and a usable CDR.

Additional Information:

Removing magicdev with "rpm -e magicdev" will make xcdroast work properly. 
Since blasting CDR's has got to be one of the most popular desktop pasttimes
these days, I suggest that magicdev be neutered in an official patch until such
time as magicdev can be taught to play nicely with the other children.  It is
not good policy to have a default installation that destroys media.
Comment 1 Eugenia Loli-Queru 2002-10-24 20:03:48 EDT
After ejecting a CD via Magicdev, about 1-2 hours later the magicdev will kill 
X itself, saying that it lost connection to the 0:0 host. Now, why MagicDev 
requires X??
Comment 2 Owen Taylor 2002-10-31 17:41:02 EST
* Note that magicdev doesn't do anything that a lot of 
  other software doesn't do also, it does it a lot
  more frequently. The only reliable way to deal with
  the fragility of CD recording is to have a way
  of locking the CD device while the burning is going
  on. We've definitely been thinking about this for
  a while, though we've had trouble coming with a good

* magicdev makes an X connection 

 - Because it displays dialogs in some cases
 - So that it will be sure to exit with the GNOME desktop

I think you have cause and effect backwards. X crashed for some
other reason, then magicdev prints a message when it exits
because it lost a connection to the X server.

*** This bug has been marked as a duplicate of 34433 ***

Note You need to log in before you can comment on or make changes to this bug.