This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 76223 - agpgart module crashes smp2.4.18-17.7.x in dual athlon
agpgart module crashes smp2.4.18-17.7.x in dual athlon
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
athlon Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-18 08:31 EDT by stuart boreen
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-18 09:45:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description stuart boreen 2002-10-18 08:31:32 EDT
Description of Problem:
Using tyan 2462mobo Nvidia geforce ultra and 3d drivers compiled from source:
NVIDIA-1.0-3123.
Everything worked up to kernel 2.4.18-10smp I used up2date to get new kernel,
made the drivers and
got a lock up with startx. NVdriver loads ok but #lsmod agpgart causes kernel
panic crash


Version-Release number of selected component (if applicable):
kernel smp2.4.18-17.7.x for athlon from up2date

How Reproducible:
always

Steps to Reproduce:

1.use tyan 2462ung with 2.12 bios & geforece Ultra agp card
2.RH 7.3 and NVIDIA 1.0-3123 .tar.gz 3d driver source
3.Boot with kernel 2.4.18-10 mem=nopentium & no apic and make install 3d
drivers, use agpgart
agp_try_unsupported=1 in /etc/modules.conf
 -- successfully use 3d!
4. Use up2date to get smp2.4.18-17.7.x
5. Boot to new kernel, Go to Nvidia directories for kernel and glx component and
#make install -- everything makes fine.
6. startx and system crashes -- hard lock up!
7. reboot and try insmod NVdriver -- ok     insmod agpgart--->kernel panic crash!
Actual Results:
crash. hard lockup.

Expected Results:
KDE desktop with 3D for Unreal Tounament or TuxRacer

Additional Information:
Comment 1 Arjan van de Ven 2002-10-18 09:02:26 EDT

*** This bug has been marked as a duplicate of 73733 ***
Comment 2 stuart boreen 2002-10-18 09:16:50 EDT
Are you sure this is a duplicate of 73733?
My kernel panics when agpgart module is insmoded, not NVdriver!
I think there may be an agp issue with the popular Tyan Thunder K7 board.
I do understand NVIDIA does not provide open source drivers.
Comment 3 Arjan van de Ven 2002-10-18 09:20:42 EDT
Then load agpgart without the nvidia module ever having loaded and send me an
oops ;)

oh and please don't use mem=nopentium
that's total bullshit (and probably broken) and the thing that it is supposed to
fix is already fixed in the RH kernels.
Comment 4 stuart boreen 2002-10-18 09:45:17 EDT
I rebooted without mem=nopentium and it works! I can load NVdriver and agpgart
in any order or just startx and all is well.
Note I had the mem=nopentium option in my grub.conf and up2date was smart enough
to use the same options for the new kernel.
You guys do good work! I should've trusted your kernel w/o the mem option.
Too bad I can't find 3D support for an ATI Radeon 9000 pro.

Note You need to log in before you can comment on or make changes to this bug.