Bug 76236 - new-kernel-pkg creates lilo lables that are too long
new-kernel-pkg creates lilo lables that are too long
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
7.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Erik Troan
David Lawrence
:
: 76437 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-18 11:38 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-26 10:52:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-18 11:38:28 EDT
Description of Problem:

While applying the 2.4.18-17.7.xsmp kernel errata, when the kernel called
new-kernel-pkg with that version as an argument, the script created a lilo.conf
entry that was too long for lilo to use.

Version-Release number of selected component (if applicable):

mkinitrd-3.4.20-1

How Reproducible:

Every machine running lilo that has had 2.4.18-17.7.xsmp applied has had this
problem.

Steps to Reproduce:
1. Install the smp errata kernel
2. try to re-run lilo
3. 

Actual Results:

Fatal: Label "2.4.18-17.7.xsmp" is too long
Comment 1 Jeremy Katz 2003-01-05 23:46:25 EST
*** Bug 76437 has been marked as a duplicate of this bug. ***
Comment 2 Erik Troan 2003-01-26 10:52:44 EST
next version of grubby will shorten (and uniqify) lilo labels automatically

amazing how few folks reported this problem. lilo must be dieing.

Note You need to log in before you can comment on or make changes to this bug.