Bug 7626 - RH 6.1 smbmount not working ! smbclient works fine!
RH 6.1 smbmount not working ! smbclient works fine!
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
sparc Linux
high Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Depends On:
  Show dependency treegraph
Reported: 1999-12-06 05:52 EST by Schalk Klee
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-02-05 16:38:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
patch to 2.2.14 kernel to fix smbmount on sparc64 (3.01 KB, patch)
2000-01-18 11:40 EST, Bill Nottingham
no flags Details | Diff

  None (edit)
Description Schalk Klee 1999-12-06 05:52:17 EST
I cannot get RH6.1 on a UltraSparc 1 to mount any SMB resources.  When I
tried to mount a resource I get "mount Error: Bad Address".

Here are the details:
## Hosts File ##       localhost       localhost.localdomain localhost      ghost           ghost.rubico.com       alice           alice.rubico.com       janice          janice.rubico.com      spectre         spectre.rubico.com      wnt-sklee       wnt-sklee.rubico.com

## SMB.CONF ###

   workgroup = rubico.com
   server string = Intranet/Internet Server
   load printers = yes
   log file = /usr/local/samba/var/log.%m
   max log size = 50
   security = user
   socket options = TCP_NODELAY
   interfaces =
   dns proxy = no
   comment = Home Directories
   browseable = no
   writable = yes
   comment = All Printers
   path = /usr/spool/samba
   browseable = no
   guest ok = no
   writable = no
   printable = yes
   comment = Temporary file space
   path = /tmp
   read only = no
   public = yes

### smbmount command & result ###

variations of command that I have tried :
smbmount //alice/rubico /mnt/smb
smbmount //ALICE/RUBICO /mnt/smb
smbmount '\\alice\rubico' /mnt/smb
smbmount '\\ALICE\RUBICO' mnt/smb
smbmount \\\\alice\\rubico /mnt/smb
smbmnt /mnt/smb -s //alice/rubico
smbmnt /mnt/smb -s \\\\alice\\rubico
smbmnt /mnt/smb -s '\\alice\rubico
etc ..

all result in the following:
[root@ghost /root]# smbmount '\\ALICE\RUBICO' /mnt/smb
mount error: Bad address
Please refer to the smbmnt(8) manual page
Added interface ip= bcast= nmask=
mount failed
Added interface ip= bcast= nmask=

## With Debug ##

[root@ghost /root]# smbmount '\\ALICE\RUBICO' /mnt/smb -d 3
smbmount started (version 2.0.5a)
Initialising global parameters
params.c:pm_process() - Processing configuration file "/etc/smb.conf"
Processing section "[global]"
doing parameter workgroup = rubico.com
doing parameter server string = Intranet/Internet Server
doing parameter load printers = yes
doing parameter log file = /usr/local/samba/var/log.%m
doing parameter max log size = 50
doing parameter security = user
doing parameter socket options = TCP_NODELAY
doing parameter interfaces =
doing parameter dns proxy = no
pm_process() returned Yes
Added interface ip= bcast= nmask=
mount error: Bad address
Please refer to the smbmnt(8) manual page
mount failed
Comment 1 Bill Nottingham 1999-12-06 12:15:59 EST
Do a 'umount /mnt/smb', and then try. Does the error change
at all?

If smbmount fails, it can leave the target directory in
a 'half-mounted' state, that needs to be umounted before
you can use the directory again.
Comment 2 Schalk Klee 1999-12-07 02:56:59 EST
The umount makes no difference at all.
Why does it report the bad address error even before it starts Samba?

Comment 3 Bill Nottingham 1999-12-08 18:13:59 EST
Because it's broken. Confirmed; broken on sparc64, works on sparc32.

Currently investigating as to why it's broken.
Comment 4 Schalk Klee 1999-12-29 09:21:59 EST
Any progress on this ?
Comment 5 Bill Nottingham 1999-12-30 12:57:59 EST
Sorry about the delay.

It's a kernel bug, it should be fixed in 2.2.14 final.
Comment 6 Schalk Klee 2000-01-06 07:54:59 EST
Any results yet ?  I see 2.2.14 was released a couple of days ago.  When can we
expect the new kernel in RPM format ?
Comment 7 Bill Nottingham 2000-01-06 11:22:59 EST
A 2.2.14 kernel will be in the next Raw Hide release, should
be today sometime.
Comment 8 Schalk Klee 2000-01-13 11:33:59 EST
I installed the 2.2.14 kernel off the rawhide.redhat.com site.

Bad news:  It did not solve the problem!

It did change the error message though.  The error message now is :

sys32_ioctl: unknown cmd fd(4) cmd(802c7502) arg(effe300)
mount.smbfs: ioctl failed, res=-1

I checked with uname -a  that the kernel version is 2.2.14-1.1.0. Smbclient to
the same smb share still works fine. It now als fails to unmount the mount point
which means you must run the umount command before you can run smbmount again.

Also got the latest version of samba (2.06a) of the server.  That made no
difference to the problem.

Comment 9 Bill Nottingham 2000-01-18 11:40:59 EST
Created attachment 63 [details]
patch to 2.2.14 kernel to fix smbmount on sparc64
Comment 10 Bill Nottingham 2000-02-05 16:38:59 EST
Fixed in 2.2.15pre kernels; a version of this will be in the next
Raw Hide release.

Note You need to log in before you can comment on or make changes to this bug.