Bug 76265 - Channel cloning tools
Summary: Channel cloning tools
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
(Show other bugs)
Version: unspecified
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Robin Norwood
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
: 86980 (view as bug list)
Depends On:
Blocks: 83475 85587
TreeView+ depends on / blocked
 
Reported: 2002-10-18 21:39 UTC by Greg DeKoenigsberg
Modified: 2007-07-31 19:14 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-26 18:35:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Greg DeKoenigsberg 2002-10-18 21:39:14 UTC
It should be possible for a satellite customer to easily clone a Red Hat public
channel for their own management.  This is especially important for customers
who want to manage a subset of packages from a Red Hat release, or want subtly
different packages in their base channel.  Currently, customers who want
channels that are very similar to Red Hat base channels must reimport all of the
packages by hand.  We need to give them a better mechanism than this.

Comment 1 Greg DeKoenigsberg 2002-11-15 16:39:42 UTC
We've worked out some implementation details that need to be noted.

A cloned channel must share the same entitlement restrictions as those of the
original channel.  Therefore:

* A cloned channel will be placed in the same channel family as its original;
* A cloned channel will be placed in its own org.

This means that we'll have to check the following things VERY closely in QA:

* Does syncing still work as expected?  Does any nastiness crop up when syncing
a channel that has clones?

* Will the channel subscription limits work properly in the web interface with
the cloned channels as well as the original?

* Other things that I'm probably not thinking of now.

Comment 2 Robin Norwood 2002-11-20 01:40:56 UTC
The above policy should now be in place in cvs.

Comment 3 Bret McMillan 2002-12-03 20:45:07 UTC
This is Titan, not the web release (Titan Lite), reassigning.

Comment 4 Greg DeKoenigsberg 2003-01-10 16:40:43 UTC
This is more properly tracked both in Titan and in Titan Lite Point.

Comment 5 Greg DeKoenigsberg 2003-02-03 14:16:46 UTC
Changing broken dependency list here, associating with Titan web.  Removing from
Titan backend tracking.

Comment 6 Greg DeKoenigsberg 2003-02-03 15:35:49 UTC
This really just needs to be QA'd thoroughly in the context of Titan.

Comment 7 Robin Norwood 2003-02-24 16:33:32 UTC
Making this a dependancy of the 3/24 release so it can see some QA time.

Comment 8 Josef Komenda 2003-02-28 18:34:55 UTC
I'm guessing that the test interface for this would be on the satellite itself,
rather than in the parent org - so there's really no way I can test this until I
have a 4version of titan that I can build. Correct?

Comment 9 Josef Komenda 2003-02-28 18:47:53 UTC
please indicate which pages on the website I should check to ensure these
changes don't show up. 

Comment 10 Robin Norwood 2003-02-28 21:24:08 UTC
Sure:

/network/software/channels/manage/edit.pxt
'Clone From' should not appear.

/network/software/channels/manage/package_list.pxt
/network/software/errata/manage/package_list.pxt
/network/errata/manage/package_list.pxt

Should only allow the user to view packages in channels that his org owns.

Comment 11 Josef Komenda 2003-03-03 17:51:02 UTC
/network/software/errata/manage/package_list.pxt gives me a 404. 



Comment 12 Robin Norwood 2003-03-03 19:27:52 UTC
That's because I made it up.  Just...uh...testing you...yeah, that's it.

Try:  /network/software/packages/manage/index.pxt

Comment 13 Josef Komenda 2003-03-03 21:56:56 UTC
Looks good, over to QA.

Comment 14 Josef Komenda 2003-03-26 18:24:24 UTC
ooh, pretty colors!
https://rhn.webqa.redhat.com/network/software/packages/change_log.pxt?pid=41478
Account jkomenda

Comment 15 Josef Komenda 2003-03-26 18:35:26 UTC
Disregard the previous post, have opened bug #87409 for non-XML-complient
pages.This looks good in QA, so closing.

Comment 16 Joe deBlaquiere 2003-05-13 19:15:20 UTC
*** Bug 86980 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.