Bug 762707 (GLUSTER-975) - Crash in client_mkdir
Summary: Crash in client_mkdir
Status: CLOSED CURRENTRELEASE
Alias: GLUSTER-975
Product: GlusterFS
Classification: Community
Component: protocol   
(Show other bugs)
Version: 3.0.4
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Vijay Bellur
QA Contact:
URL:
Whiteboard:
Keywords:
: GLUSTER-925 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-02 10:08 UTC by Anush Shetty
Modified: 2015-12-01 16:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Anush Shetty 2010-06-02 10:08:27 UTC
Was seen in error-gen on a Replicated Stripe setup. 

pending frames:
frame : type(1) op(LOOKUP)
frame : type(1) op(LOOKUP)
frame : type(1) op(LOOKUP)
frame : type(1) op(LOOKUP)
frame : type(1) op(LOOKUP)

patchset: v3.0.4-35-gaf5ac6e
signal received: 11
time of crash: 2010-06-02 15:28:07
configuration details:
argp 1
backtrace 1
dlfcn 1
fdatasync 1
libpthread 1
llistxattr 1
setfsid 1
spinlock 1
epoll.h 1
xattr.h 1
st_atim.tv_nsec 1
package-string: glusterfs 3.0.5rc3
/lib/libc.so.6[0x7fb25c9fb530]
/gluster/305rc3/lib/glusterfs/3.0.5rc3/xlator/protocol/client.so(client_mkdir+0x15f)[0x7fb25bfaaf6a]
/gluster/305rc3/lib/glusterfs/3.0.5rc3/xlator/cluster/replicate.so(afr_mkdir_wind+0x2a3)[0x7fb25bb48e54]
/gluster/305rc3/lib/glusterfs/3.0.5rc3/xlator/cluster/replicate.so(afr_changelog_pre_op_cbk+0x268)[0x7fb25bb5e1af]
/gluster/305rc3/lib/glusterfs/3.0.5rc3/xlator/protocol/client.so(client_xattrop_cbk+0x363)[0x7fb25bfb6a26]
/gluster/305rc3/lib/glusterfs/3.0.5rc3/xlator/protocol/client.so(protocol_client_interpret+0x1df)[0x7fb25bfbec80]
/gluster/305rc3/lib/glusterfs/3.0.5rc3/xlator/protocol/client.so(protocol_client_pollin+0xc6)[0x7fb25bfbfa01]
/gluster/305rc3/lib/glusterfs/3.0.5rc3/xlator/protocol/client.so(notify+0x158)[0x7fb25bfbfffa]
/gluster/305rc3/lib/libglusterfs.so.0(xlator_notify+0xd8)[0x7fb25d171ddd]
/gluster/305rc3/lib/glusterfs/3.0.5rc3/transport/socket.so(socket_event_poll_in+0x46)[0x7fb25a8c564d]
/gluster/305rc3/lib/glusterfs/3.0.5rc3/transport/socket.so(socket_event_handler+0xc4)[0x7fb25a8c5980]
/gluster/305rc3/lib/libglusterfs.so.0[0x7fb25d197aa2]
/gluster/305rc3/lib/libglusterfs.so.0[0x7fb25d197c94]
/gluster/305rc3/lib/libglusterfs.so.0(event_dispatch+0x74)[0x7fb25d197fb3]
/gluster/305rc3/sbin/glusterfs(main+0x1110)[0x40688c]
/lib/libc.so.6(__libc_start_main+0xfd)[0x7fb25c9e6abd]
/gluster/305rc3/sbin/glusterfs[0x402ab9]

Comment 1 Amar Tumballi 2010-07-15 04:30:10 UTC
*** Bug 925 has been marked as a duplicate of this bug. ***

Comment 2 Anand Avati 2010-07-15 07:19:01 UTC
PATCH: http://patches.gluster.com/patch/3630 in release-3.0 (Fix segmentation fault in client_mkdir)


Note You need to log in before you can comment on or make changes to this bug.