This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 762778 - (GLUSTER-1046) fd_t * being accessed after fd_unref()
fd_t * being accessed after fd_unref()
Status: CLOSED NOTABUG
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
mainline
All Linux
low Severity low
: ---
: ---
Assigned To: Shehjar Tikoo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-03 20:30 EDT by Krishna Srinivas
Modified: 2010-08-12 05:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: nfs
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Krishna Srinivas 2010-07-03 20:30:49 EDT
nfs3svc_remove_cbk():
         if (openfd) {
                fd_unref (openfd);
                nfs3_fdcache_remove (nfs3, openfd);
         }

openfd is being accessed after unref() if it is the last unref then it might segfault
Comment 1 Shehjar Tikoo 2010-07-03 21:58:06 EDT
(In reply to comment #0)
> nfs3svc_remove_cbk():
>          if (openfd) {
>                 fd_unref (openfd);
>                 nfs3_fdcache_remove (nfs3, openfd);
>          }
> 
> openfd is being accessed after unref() if it is the last unref then it might
> segfault

This is not a bug. NFS has a fd cache which holds the last reference so it is ok for the fdcache code to access fd after it is unref'ed for a remove op.

Note You need to log in before you can comment on or make changes to this bug.