Bug 76292 - User manager does not open
User manager does not open
Status: CLOSED DUPLICATE of bug 68245
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-users (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Depends On:
  Show dependency treegraph
Reported: 2002-10-19 09:28 EDT by Michael
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-10-22 16:31:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael 2002-10-19 09:28:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
I am having problem with the user manager that is in Xwindows. everytime I 
click on it to open it nothing happens.  all it does is bring up the question 
about authorization. asking if I would like to keep the authorization or for 
get it. I just installed linux on my Machine last night and I can't seam to 
figure out why the user/group manager is not working not working  

I have tried to run the redhat-config-user from the terminal commad window 
from xwindows and it came up with a segmention fault here is the 
fault /usr/share/redhat-config-users/redhat-config-users: line 4 1696 
segmantation fault	  /usr/bin/python2.2 /usr/share/redhat-config-
the 1696 is a diferant number every time

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.click on user/group in the kde menu

Actual Results:  nothing happens

Expected Results:  It should have brough up the user manager

Additional info:
Comment 1 Michael 2002-10-19 23:04:46 EDT
I have also tried to delete my user password by typing passwd -d then the user
name and it also came up with a segmentation fault that is all it said.  I do
not know if this has anything to do with the other problem or not but I do
beleave the problem is related.
Comment 2 Brent Fox 2002-10-21 11:09:14 EDT
Have you edited /etc/passwd by hand?  Also, did you specify in the installer or
authconfig to use MD5 passwords?
Comment 3 Michael 2002-10-21 18:10:15 EDT
I have loaded up the /etc/passwd in a text editor after I notice nothing would 
work but did not edit it. I do have tha ability to do so however. I have 
reinstalled linux 4 times and I tried it with and without MD5 passwd. I have 
also tried it with and without shadow passwd
Comment 4 Michael 2002-10-21 18:38:33 EDT
I have also tried to edit the about myself in the control center and after
typing in my passwd it came up with "unknown error" in a window and an ok button
I wonder if all these problems are related.
Comment 5 Brent Fox 2002-10-22 11:42:19 EDT
My guess is that they are all related.
Comment 6 Brent Fox 2002-10-22 16:31:35 EDT
Ok, I can reproduce this crash if I select to not use MD5 passwords and shadow
passwords during the install.
Comment 7 Brent Fox 2002-10-22 16:36:42 EDT
However, this is a libuser bug and not a redhat-config-user bug.  To
demonstrate, do the following as root:
1) # /usr/bin/python
2) >>> import libuser
3) >>> admin = libuser.admin()

Segmentation fault.  

This bug is a dupe of bug 68245.

*** This bug has been marked as a duplicate of 68245 ***
Comment 8 Michael 2002-10-22 19:50:14 EDT
I can reproduce the problem with or with out MD% or Shadow password.  the things
you wanted me to do as root.  I do not get the error unless I have the MD5 password.

Note You need to log in before you can comment on or make changes to this bug.