This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 762967 - (GLUSTER-1235) Bug for all pump/migrate commits
Bug for all pump/migrate commits
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
mainline
All Linux
low Severity low
: ---
: ---
Assigned To: Pavan Vilas Sondur
:
: GLUSTER-1572 763518 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-27 10:39 EDT by Pavan Vilas Sondur
Modified: 2011-01-04 07:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pavan Vilas Sondur 2010-07-27 10:39:22 EDT

    
Comment 1 Anand Avati 2010-08-06 04:09:10 EDT
PATCH: http://patches.gluster.com/patch/4007 in master (add pump xlator and changes for replace-brick)
Comment 2 Anand Avati 2010-08-16 00:38:54 EDT
PATCH: http://patches.gluster.com/patch/4137 in master (cluster/pump: Save path (/) when abort is received in pump.)
Comment 3 Vijay Bellur 2010-09-06 02:21:55 EDT
PATCH: http://patches.gluster.com/patch/4571 in master (misc replace-brick fixes)
Comment 4 Vijay Bellur 2010-09-08 04:13:09 EDT
PATCH: http://patches.gluster.com/patch/4656 in master (mgmt/glusterd: Various replace brick changes.)
Comment 5 Vijay Bellur 2010-09-10 06:53:41 EDT
PATCH: http://patches.gluster.com/patch/4729 in master (mgmt/glusterd: set req in opinfo)
Comment 6 Vijay Bellur 2010-09-14 06:35:28 EDT
*** Bug 1572 has been marked as a duplicate of this bug. ***
Comment 7 Vijay Bellur 2010-09-21 03:52:04 EDT
PATCH: http://patches.gluster.com/patch/4884 in master (fix the typo in the getxattr of replace-brick)
Comment 8 Vijay Bellur 2010-09-23 07:58:19 EDT
PATCH: http://patches.gluster.com/patch/4947 in master (mgmt/glusterd: Misc fixes to pump / cli / glusterd wrt replace brick.)
Comment 9 Vijay Bellur 2010-09-27 22:07:32 EDT
PATCH: http://patches.gluster.com/patch/5021 in master (replace brick fixes)
Comment 10 Vijay Bellur 2010-09-29 01:43:23 EDT
PATCH: http://patches.gluster.com/patch/5060 in master (whitespace cleanup)
Comment 11 Vijay Bellur 2010-09-29 01:43:27 EDT
PATCH: http://patches.gluster.com/patch/5061 in master (replicate: replace first-write-to-flush optimization)
Comment 12 Vijay Bellur 2010-09-29 01:43:37 EDT
PATCH: http://patches.gluster.com/patch/5064 in master (replicate: clear pre_op_done/piggyback values after open fd self-heal)
Comment 13 Vijay Bellur 2010-09-29 06:18:17 EDT
PATCH: http://patches.gluster.com/patch/5083 in master (pump: skip "." and ".." entries while traversing dir tree)
Comment 14 Vijay Bellur 2010-09-29 06:34:45 EDT
PATCH: http://patches.gluster.com/patch/5087 in master (replicate: remove checks which prevented self-heal when open fds were present)
Comment 15 Vijay Bellur 2010-09-30 11:19:31 EDT
PATCH: http://patches.gluster.com/patch/5118 in master (glusterfsd: perform init new graph if re-configure fails)
Comment 16 Vijay Bellur 2010-10-01 01:02:51 EDT
PATCH: http://patches.gluster.com/patch/5132 in master (mgmt/glusterd: Make replace-brick atomic)
Comment 17 Vijay Bellur 2010-10-02 07:04:29 EDT
PATCH: http://patches.gluster.com/patch/5193 in master (cluster/pump: Do not do lookup if it is "." and ".." in pump.)
Comment 18 Vijay Bellur 2010-10-04 07:18:25 EDT
PATCH: http://patches.gluster.com/patch/5241 in master (cluster/pump: mgmt/glusterd: Misc fixes for replace-brick)
Comment 19 Vijay Bellur 2010-10-04 11:37:42 EDT
PATCH: http://patches.gluster.com/patch/5256 in master (cli: mgmt/glusterd: Add commit force op to replace-brick)
Comment 20 Vijay Bellur 2010-10-08 06:05:13 EDT
PATCH: http://patches.gluster.com/patch/5361 in master (mgmt/glusterd: Fix replace brick to pass src-brick and dst-brick port nos properly.)
Comment 21 shishir gowda 2010-10-08 21:41:29 EDT
*** Bug 1786 has been marked as a duplicate of this bug. ***
Comment 22 Vijay Bellur 2010-10-18 03:25:49 EDT
PATCH: http://patches.gluster.com/patch/5505 in release-3.0 (replicate: replace first-write-to-flush optimization)
Comment 23 Vijay Bellur 2010-10-18 03:25:53 EDT
PATCH: http://patches.gluster.com/patch/5506 in release-3.0 (replicate: remove checks which prevented self-heal when open fds were present)
Comment 24 Anand Avati 2010-10-30 21:23:16 EDT
PATCH: http://patches.gluster.com/patch/5604 in master (mgmt/glusterd: Start nfs before killing source brick in replace brick commit.)
Comment 25 Anand Avati 2010-12-12 20:07:37 EST
PATCH: http://patches.gluster.com/patch/5841 in master (set the return value to -1 intitially which may be returned as success in validate_or_goto)

Note You need to log in before you can comment on or make changes to this bug.