Bug 76302 - Norwegian LANG settings are wrong.
Norwegian LANG settings are wrong.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: man (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-19 12:21 EDT by Need Real Name
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-29 11:35:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-19 12:21:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
When you choose the Norwegian installation $LANG is set to :
no_NO.UTF-8
with makes a lot of text seem bad.
Changing $LANG to no_NO fixes the bug for the console (haven't checkt GNOME). 

 cat /etc/sysconfig/i18n
LANG="no_NO"
SUPPORTED="no_NO.UTF-8:no_NO:no"
SYSFONT="LatArCyrHeb-16"


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install 8.0 clean w/ norwegian as your lang settings.
2. login 
3. man tar :)

	

Actual Results:  the texts are all vierd with ^ etc instead of -

example:
tar  [ b ] A bbcatenate bbconcatenate | c bbcreate | d bbdiff bbcompare
       | r bbappend | t bblist | u bbupdate | x bextract bbget [  bbatimebpreb
       serve  ]  [  bb,  bbblockbsize  N  ]  [  bB, bbreadbfullbblocks ] [ bC,
       bbdirectory DIR ] [ bbcheckpoint    ] [ bf,  bbfile  [HOSTNAME:]F  ]  [
       bbforceblocal    ]  [ bF, bbinfobscript F bbnewbvolumebscript F ] [ bG,
       bbincremental ] [ bg, bblistedbincremental F ] [ bh, bbdereference ]  [
       bi,  bbignorebzeros ] [ bj, bI, bbbzip ] [ bbignorebfailedbread ] [ bk,
       bbkeepboldbfiles ] [ bK, bbstartingbfile F ] [ bl, bbonebfilebsystem  ]
       [  bL, bbtapeblength N ] [ bm, bbmodificationbtime ] [ bM, bbmultibvolb
       ume ] [ bN, bbafterbdate DATE, bbnewer  DATE  ]  [  bo,  bboldbarchive,
       bbportability  ]  [  bO, bbtobstdout ] [ bp, bbsamebpermissions, bbpreb
       servebpermissions ] [ bP, bbabsolutebpaths ] [ bbpreser

Expected Results:   tar  [ - ] A --catenate --concatenate | c --create | d
--diff --compare
       | r --append | t --list | u --update | x -extract --get [  --atime-pre-
       serve  ]  [  -b,  --block-size  N  ]  [  -B, --read-full-blocks ] [ -C,
       --directory DIR ] [ --checkpoint    ] [ -f,  --file  [HOSTNAME:]F  ]  [
       --force-local    ]  [ -F, --info-script F --new-volume-script F ] [ -G,
       --incremental ] [ -g, --listed-incremental F ] [ -h, --dereference ]  [
       -i,  --ignore-zeros ] [ -j, -I, --bzip ] [ --ignore-failed-read ] [ -k,
       --keep-old-files ] [ -K, --starting-file F ] [ -l, --one-file-system  ]
       [  -L, --tape-length N ] [ -m, --modification-time ] [ 

Additional info:
Comment 1 Bill Nottingham 2002-10-21 00:44:54 EDT
The settings aren't wrong; this is an issue with man (or possibly your terminal.)
Comment 2 Need Real Name 2002-10-21 09:05:03 EDT
The issue is quite generic for most programs and this is a stock RH 8.0 install
( no funny changes in the terminalsettings). I guess it comes as RH is not
complely UTF-compliant?

Are there ways to give you input on the issue that might be relevant in removing
the errors ?
Comment 3 Eido Inoue 2003-07-29 11:35:51 EDT
UTF-8 issues with groff and man are fixed in 9

Note You need to log in before you can comment on or make changes to this bug.