Bug 763142 - (GLUSTER-1410) nfs uses this for child translator during frame creation
nfs uses this for child translator during frame creation
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
3.1-alpha
All Linux
low Severity medium
: ---
: ---
Assigned To: Shehjar Tikoo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-20 09:27 EDT by Shehjar Tikoo
Modified: 2015-12-01 11:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: RTP
Mount Type: nfs
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shehjar Tikoo 2010-08-20 09:27:03 EDT
this must always point to the current translator.

Will put better description after I understand the problem.
Comment 1 Shehjar Tikoo 2010-08-31 04:55:23 EDT
The problem is that the frame creation logic in the nfs-fops layer creates frames with the frame root set to the child subvol over which the fop will be issued. This is wrong behaviour because when the callback returns, nfs callbacks will have this set to the child subvolume, which is incorrect. this should always be set to the translator which is handling a callback.
Comment 2 Vijay Bellur 2010-08-31 07:45:07 EDT
PATCH: http://patches.gluster.com/patch/4424 in master (nfs: Create frames with frame->root as nfsx)
Comment 3 Vijay Bellur 2010-08-31 07:45:11 EDT
PATCH: http://patches.gluster.com/patch/4427 in master (nfs, mount3: Fix assumptions of this being child xl)
Comment 4 Shehjar Tikoo 2010-08-31 22:58:54 EDT
Keeping unresolved till I figure out a way to reproduce.

Note You need to log in before you can comment on or make changes to this bug.